Rectangle not holding


#1

When I start drawing a rectangle by clicking and releasing and then dragging it out, I then click and release again and the rectangle disappears, Why?
I need answer a.s.a.p.


#2

There’s not enough information in your post to give you a good answer. Can you draw anything? What happens if you try the Line tool. Can you draw a line? Can you draw a rectangle with the Line tool? Can you draw a circle?


#3

To add to what @DaveR asked, are you drawing a rectangle on another surface? If there IS existing geometry, can you share (or at least post an image) of where you are trying to draw?


#4

Or could you be drawing on a layer that is hidden? So when your geometry has been drawn, it gets hidden immediately? Try turning on hidden geometry (View/Hidden Geometry) to see if that might be the case?

[NOTE: You may already know this, but if not, it’s worth repeating. You should ALWAYS draw geometry on Layer0, and not hide that layer. To control visibility, make geometry into components or groups as you finish drawing a piece of the model, and assign a visibility layer to the component or group, NOT the geometry inside it.]


#5

Have you got edges turned off.
Go View /Edge Style and Tick Edges on.


#6

Thanks for the prompt replies, I will answer all suggestions

DaveR The only way I can draw rectangle, circle, or line is by keeping the mouse button down while I move it

TheOnly Aaron, As above, however if I draw with the button down and then try putting in measurement they do not correct what I have drawn

John_mcclenahan, I have checked Hidden Geometry and all appears correct.

Box, Edges are on

I have only had the program for a week so am very new at it although I have used other program without problems.


#7

Check your Preferences…

…you may have Click Style set to Click-drag-release


#8

Aaron, Many thanks
That’s 1 problem solved, however I still can’t set my dimensions any suggestions?


#9

What are you doing to set the dimensions? Are you attempting to click in the Measurements box before typing? If so, don’t. Assuming you’ve set the Click Style to Auto detect as shown in Aaron’s screenshot, drag out the rectangle clicking to set the second corner, let go of the mouse and just start typing the dimension. Type it in the format x,y (x comma y) unless you use the comma as a decimal separator in which case it would be x;y (x semicolon y). After typing in the dimension, hit Enter.


#10

DaveR, Thanks, I must be getting old, I forgot about hitting enter and just clicked the mouse.
All OK now.
Many thanks to all who had a go at helping.