Rectangle measurments

when i draw a rectangle and type in measurements, i don’t know which measurement i have to type in first. Is there any good fast tricks to remember this?
I know that order of axis is:

  1. red
  2. green
  3. blue
    But sometimes im deep in model and i cannot see exact axis.
    Or is there a shortcut to turn it around fast if i go wrong way?


When you perform your first click and move the cursor, pay attention to the measurement readout and see which one is larger. That is your indicator. Wish there was a rule :slight_smile:

Since I can never remember whatever rule there may be, I always drag a rectangle to an exaggerated aspect and then look at the measurements window to see whether the longer side came first or second. It’s easier once you have existing stuff at the corners so you can snap to that.

This is how im doing it so far, but when you have some numbers to remember it can get frustrating :smile:

1 Like

Well, you can always go the slower way and set some guides first.

My impression is that the direction you first move your mouse governs which dimension is the bigger one - it’s the one your first move makes longer than the other. Pity it isn’t consistently x, y.

1 Like

I just tried to input some measurements for a rectangle in SU 2021 but it doesn’t work. When I try to enter a value I get a red prompt message pop up on the cursor “constraints not appropriate at this time”.
2021 bug or am I the only one. I’m pretty sure it was working yesterday…weird.

Caps Lock.

Makes no difference if CAPS LOCK on or not.

I’ve seen this and I can’t remember what it was. Thought it was caps lock.

Num Lock?

Same applies for a line. Something has broken in SU or something weird going on. I really need to be able to enter measurements to make stuff quickly & accurately & I got work to do. I did get a new router yesterday so I’m on a new connection. I noticed SU seems slow to open up today. Could that be causing any issues. I’m signed in etc. Checked for updates…all good.

So you aren’t clicking in the Measurements window are you? You’ve been at this long enough you probably think that’s a dumb question but…

Dam, just worked out Num Lock isn’t working on my keyboard…top numbers work…nuthin’ to do with SU. My bad…lol. :roll_eyes: