Reconnect to Model? Why? Huh?


#1

Why is it in Layout 17 you need to reconnect to model?
Especially dims and notes…
I’ve never had to do this is previous versions.
Every time I update I have to do this???
Why is this happening in this version?
Frustrated to say the least…


#2

Yes. It can be frustrating when you don’t understand a feature. The reason is that the dimensions are actually connected to the model now. They weren’t before. So if you update the model, say make something longer, the dimension will update to show the change. In the past you would have to replace the dimension with a new one. If you’re looking at older LO files, they’ll need to have the dimensions reconnected because LayOut never had a chance to do it previously. You can select all of the dimensions shown in red or even everything on the page, right click on one of the red dimensions and choose Reconnect.


#3

Dave, I am well aware to the new feature. It has bugs and needs to be updated. Having to reconnect to the model every time should be automatic.


#4

It shouldn’t be doing that. I’ve done half a dozen or more plans projects using LO 2017 and except for a couple of cases using older SKP files that required reconnecting once, I haven’t had any issues with it. A few minutes ago I finished up two project plans with over 100 dimensions on each. No problem with needing to reconnect dimensions at all. There must be something different between what I’m doing and what you’re doing.


#5

Dave,
Are you on a Mac or PC?
I am running OS X 10.11.6


#6

I use both Mac and PC.


#7

For me personally reconnecting issue appears only when I update skalp section. Any dimensions connected to Skalp section (almost all on top views and cuts) goes red and need to be reconnected, until you update skalp again. Other dimensions that are connected to model itself works just fine. (I use mac)


#8

The red highlight appears when LO detects that whatever the dimension was connected to in the model has been replaced with a new PID (or if it never had a connection as happens with older SU models. Skalp is most likely replacing entities so there’s a new PID.


#9

Lets hope skalp will fix it. Would be nice to have option to switch red color off or change the color to something other. I’m using red dimensions for something important or to be confirmed. So now it blends with all other red ones :slight_smile:


#10

If you explode the dimensions, they will no longer show as needing to be reconnected when the PID gets replaced. Of course they won’t update automatically, either.


#11

Will change my red/importand color to something else I guess :slight_smile:


#12

Hi,

You can disable the highlighting by going to View > Warning Symbols and unchecking “Disconnected Annotations”. This will suppress all drawing of the red highlights on disconnected dimensions and labels. Note that these annotations will still in fact be disconnected, you just won’t know whether they are or not.

Hope this helps,
Adam


#13

I like this feature but I am struggling to understand how it operates sometimes. It seems a bit arbitrary.

For example, I have just opened a LO file and used that to open the SU file. I then added something new that was unconnected to anything already drawn. When I came back into LO a few, but not all, annotations were in red. Most simply needed reconnecting (but why?). One stubbornly refused to be reconnected. I have had that happen a few times. The only option then seems to be to delete and re-do it.


#14

The idea is a great one but it is happening on every page every time I reopen, hi lighting all dimensions that haven’t changed in the model so I am selecting and reconnecting about 400 times a day. Not much fun when you have a deadline on a project. Am I doing something wrong? I don’t really want to disable it but I’m going to have to if I can’t fix it.


#15

You don’t have to select and reconnect them one at a time. Select all the dimensions on the page and reconnect those that need it in one go.

Most likely because it isn’t a normal thing. If you’ve changed the model in some way that forces a rewrite of the PIDs, you could wind up with this problem.

Are you making sure to prevent the viewports from showing the scenes as modified?

How about sharing a LayOut file so we can see your exact setup?


#16

Hi Dave

Thanks for your comments and no I am not selecting them one at a time. Its 2 buildings with about 12 output sheets each. Having now read some of the earlier comments on this thread I am thinking it is because of Skalp. All the drawings are floor plans or cross sections generated from Skalp model cuts. I am trying a lot of iterations to get the output drawings to look right. I am having trouble getting Skalp depth clipping to show on the layout sheet. What is a PID ? I cant share the model right now but i will try an post something when I am back at my PC. Also wondering whether my work PC running windows 7 is a problem. The connection seems better on my laptop with windows 10. it updates the SU model automatically.
thanks
H


#17

Skalp does seem to be problematic. Since you are using it and seeing the same issue, you likely hit the issue.

PID is Persistent ID. That what allows LO dimensions to remain connected to the model.


#18

I am having a problem with dimensions not reconnecting. I am experienced with how to reconnect dimensions by right-clicking, and choosing “Reconnect to Model.” This has worked in the past, but now the dimension remains red. I have about 50 dimensions in red now on a current design. I have tried to reconnect each one individually and selecting them all at once, plus I have closed/restarted both SketchUp and Layout, but they remain red! Any suggestings other than spending time replacing all of the dimensions.


#19

When I’ve had this happen, it’s been due to at least one of the points in the model being removed so there’s nothing for the dimension to reconnect to. When I don’t want to deal with replacing them, I select the disconnected ones and explode them. While they are still selected, I turn on Fill in Shape Style.

One example that I’ve seen where this happens is if the dimension is linked to a guide point that later gets deleted from the model. Without the guide point the dimension has no connection to make.


#20

I tired exploding them, but the all of the lines etc. disconnected from the number and the ones with the number centered now had the line striking through the number. I went ahead and deleted all of the dimensions and redid them. Thanks.