Layout dimensions Red box on measurement

On occasion when I open a SU2020 Layout file, many of the dimensions have a red box on them. I select the dimension object and “reconnect to Model” to fix the problem.

What causes this and is there a way to avoid it? The individual dimension selection and recconnects is quite time consuming.


That means those dimension need to be reconnected to the model. You can select them, right click on one and choose Reconnect. If you’ve changed the geometry in the model–replaced edges or something–the dimensions may not reconnect because the IDs for the entities will have changed. In that case you would just replace the dimension.

As far as avoiding it altogether, you could explode the dimensions so they aren’t connected to the model. Downside is they won’t update if you make changes in the model.

If you select multiple by dragging a selection box and rightclick, doesn’t the ‘Reconnect to Model’ option appears?

Hi, I’ve got this problem and it isn’t fixed by doing the reconnect that you describe - any other advice?

What version of SketchUp and LayOut? What operating system? Complete your profile so we can give you some correct direction to fix it.

SU Pro 2021, PC Windows … but have just read that the red dimensions don’t print so it isn’t too much of a problem, just a minor niggle!

Please complete your profile.

As long as the dimensions still correctly reflect the dimensions in the model it won’t be.

You can edit the dimensions and move the red dots so they relink to the model if needed.

how do I complete my profile? I just had a look but couldn’t see…

there aren’t any red dots…

Click on the R in the green circle in the upper right corner of the forum screen. Then click on Preferences–the person icon–followed by the gear icon.

You haven’t opened the dimension to edit it. Double click on it. They are blue here because the dimension isn’t connected to anything but one or both of the dots would be red if it’s become disconnected from the model.
Screenshot - 1_12_2022 , 12_06_52 PM

thanks - when I do this, the dots are in the right place

If you know the dimensions are good, you can turn them of in [menu] View > Warning Symbols