Random extra faces added

I’m trying to design something involving four equal segments to be 3D printed.The problem I have is as shown here that it sometimes adds an extra segment as shown and sometimes it doesn’t,there doesn’t seem to be any particular pattern as to why or when it does this.The four segments are EXACTLY equal at 90 degrees each,all the same width and all the same height.
So either how can I stop it from adding these in the first place,or how do I lose the bit I don’t want without ending up with a hole in that particular face?

(Sorry for what’s probably a very basic user error type of question).

can you post the skp?

it’s impossible to see what’s right or wrong from that view…


1 Like

lifter1.skp (129.4 KB)

On this view they’re at 8 o’clock and 10 o’clock.Look at them end on and they do slant upwards a bit more than the rest of that surface.

Yes I know it has really got enough sides to it,that’ll be fixed in the final version.

Turn on “hidden geometry” and you will see why. Loads of different ways to “fix” it; depends on what form/how you want the finished product to to look.

lifter1 - edit.skp (163.8 KB)
(made one angled tooth a component and rotated it… and tidied up a little bit of geometry. You will probably have to explode it for 3D printing.)

1 Like

I can see the hidden geometry now,but still don’t understand why some do it and some don’t do it? Thanks for the ‘fix’ by the way,there will be a mirror image of this part that will rest on top of it,the idea is that this part rotates and the top part will lift up so the faces of the ‘teeth’ need to be nice and smooth.

Anyone please I’d still like to know the answer to this one?

Unfortunately, I don’t know that anyone will be able to tell you why they are different. I can say, though, that, if you want them to be exactly the same, then you should model one piece, group it, and then use Alt_Rotate to duplicate them. Tat way all four pieces will have exactly the same geometry.

1 Like

The answer necessarily lies in the way you constructed the cam. Since the four ramps are not identical, clearly you did something different as you drew them. Most likely not paying close attention to inference points. But without watching over your shoulder I can’t tell you what it was. @TheOnlyAaron beat me to the post with the method I would also use: draw one and then rotate copies to create the other three.

1 Like

Woot! I beat a Sage to the punch! Sorry to celebrate, @slbaumgartner, but you guys are just so fast!

Here is a quick GIF of the process:

1 Like

Make the first copy with the rotate tool as Aaron has shown then let go of the mouse and type 3x and hit enter.

1 Like

Ok thanks for the replies everyone,think I’ve figured it out now.But I have to use Ctrl rotate to make it work as shown above?

Yes, pressing ctrl (alt/option on Mac) toggles the move and rotate tools between direct move/rotate and move/rotate a copy. If you watch closely in the animation Aaron posted earlier, you can see a little “+” appear next to the cursor when he hits the ctrl key.

And here it is again. Ctrl to start the copy, rotate any amount then type what you want and hit enter to confirm.
In this case we know it is 90 because you want the four quadrants, then 3x to make a copy three times.
Watch the measurement box at the top. As I type on the keyboard.
It’s actually only two mouse clicks to create the whole array. One to set the rotation point the second to start the copy/rotate action, the rest is all typing.

Another little tip relating to your original question.
They aren’t random faces they are SU trying to fill the space, sometimes it gets it wrong.
You can see the stretch mark in the face as well as the hard edge and angle change. This is caused by the underlying geometry not being optimal.
Turn on hidden geometry so you can see the edges that are making the face.
You can see the top few sections are not really connecting to the best endpoints to get an even surface.
Delete them and stitch them in a better arrangement and you get a smooth face.

Should we call this gif type with keyboard “animated gif extended”? (I like it)

(Is that your new animated gif toolbar at the top? Clever too…)

It’s actually the way I work most of the time @Cotty .
I find having the floating toolbar with the basics and the floating keyboard positioned appropriately for where I’m working means I keep both hands on Mouse and Space mouse and rarely need to go for the hardware keyboard. I use the same setup when working with my touchscreen and stylus. Left hand driving, right hand drawing. Right click and ctrl on the space mouse buttons.
It was only recently I noticed you could use the Measurement toolbar as the basis for your custom set. So now I use that all the time, so those tools and VCB are always close at hand.

1 Like

Ok thanks for the replies everyone,I find the animations a LOT easier to follow than when they’re explained with words on a computer screen.

I’ve had the parts printed,but this has happened…

4404193a-99e4-4e08-9c54-59fb4c26196c by Chris Plunkett

Now this is obviously my fault as somehow I haven’t properly duplicated each segment.I did it by copy and pasting the first one another three times before I knew about the above mentioned method.So I’ll do it again using Ctrl-rotate etc and see what happens.

Ok,so I’ve redesigned it with all identical segments,but am still getting this…

lifter1 by Chris Plunkett

Any ideas why anyone please?

You might try making the edges around the perimeter vertical, (on the blue axis). You have points on the slope overhanging the circle at the base. This cleanup will result in fewer lines and faces as well.


Aaaahhh ok,I hadn’t noticed the sides weren’t vertical,which would explain the gap.I pulled the whole segment up,and then moved one end down,how would this make the sides not vertical?

Also I made it using as many segments as possible to make the outside edge as smooth as possible when it’s printed,or is this not really necessary in cases like this?