PushPull ongoing drama

Hi

Thanks to this forum I now believe I know how to do push pull but I am unable to do so in two particular areas of my drawing. I have tried deleting and redrawing the walls. I have checked the walls are parallel and I have checked for marks on the other side of the walls. I am now scratching my head trying to work out what I am missing. Can anybody please advise?
Both doors are on the same right side of the drawing - one is a double door - I have also tried p/p a simple square + door to the left of this. Link to drawing is below. Many thanks

If you turn edges by axis color on you can see that the wall is “off axis” but the rectangle you are trying to pp through it is “on axis”, it would be best to correct the wall that is off axis and go from there.

off%20axis

Vernon stuck (SU 2018).skp (3.8 MB)

Change your style to one of the basic ones, simple for example, Turn off shadows and untick use sun for shading, Use monochrome and perspective.
This gets rid of the sketchy edges and weird watermark and will help you see what you are doing.
Also. Be aware that lots of things you delete are still stored in the model until you purge them. Go to Window/Model Info/Statistics and click purge unused. This will reduce your file size to one that is possible to upload directly to the forum.
With these settings you can immediately see that your doors are not touching the wall in one case and not aligned to the wall in the other.
There are also stray edges and loose geometry floating around that you can see to clean up. I suspect there are layer issues also but my pc has overheated and crashed so I can’t be specific on that.

Spend some time at the Learning Center. View the tutorial Sketchup Fundamentals. Lots of good info.

Thanks Box this is really helpful I think Im trying to get ahead of myself. Hope you get the PC sorted :slight_smile:

Thanks Im already doing this - its very useful :slight_smile:

Can you pls advise how to turn on edges by axis colour - I cant seem to find it. Many thanks

You set it in the edges section of your style.
By%20Axis

Either find an existing style that is set “by axis” of save a new one. I keep one handy in my style collection.

Thank you @Box for the clever video explanation. I have been looking for the color by axis option as well and even following your guide it simply was not there. However, below the lowest “jitter” option there is a grey line and if you hover immediately below that you get expand up and down arrows appear. Use those to fully open the window …and there is the color option!