Push/pull tool error


#1

I am a newbie with sketchup, and I’m having a problem with the push/pull tool. I made groups that I want to push/pull. For some reason it won’t let me, I’ve tried clicking, double clicking, triple clicking but it always gives me a red circle with a line through it. I’ve tried “exploding” the object, but it still won’t let me push/pull any groups. Please help. I would greatly appreciate any guidance or suggestions.
Thank you


#2

And what color is the selected group?

If it’s Red too, then you have Locked that group… and you’ll need to unlock it before you can make any edits to it.

Right-click on the object, and choose unlock. Once the Red selection box turns Blue, you should be able to edit objects again.


#3

You pushpull a face, not a group. To edit a group, you double-click to enter into it’s entities context (you’ll see the bounding box become a dotted lines.) Sometimes there can be nested groups and component instances, and you have to “drill down” into each level by double-clicking again.

Open the EntityInfo inspector (from the Window menu,) so you can see what you are clicking on.


#4

Hello thank you so much although I still haven’t quite figured it out. When I select the group or any of the faces it’s blue. I tried right clicking but it didn’t give me an option to unlock? I was able to open up the entity info. That helps to kind of see what you’re doing. Any other ideas? Thanks for your help, I will keep trying.


#5

A screen shot or the model would help us see what the problem may be.
Use the upload button at the top of the message box to attach files.


#6

The geometry inside a Group or Component is isolated from the rest of the model.
Like a ship in a bottle, you can see it but you can’t work with it unless you enter the bottle.

Using the Select Tool, double-click on a Group or Component to enter its editing context.
Then switch to the Push/Pull tool or others you need to work with the geometry
Click once in empty space to close its editing context.

Best practice is to keep the Entity Info box open as you’re modeling.
It’s your guide to understanding what you’re working with and provides editing options as well.

Here’s more about working with Groups and Components and the Push/Pull tool.




#7

I can enter the group, but it’s not giving me a dotted blue surface like it usually does. I am able to push/pull it before making it a group in this way, but once it’s grouped it shows me a red circle next to my push/pull icon/the mouse, after I select the object (blue borders) and I select my push/pull tool as soon as I select my push/pull tool my object no longer has it’s blue borders. ?


#8

I tried to do a screen shot, but my mouse did not show up on the screen shot. I think part of the problem happening is that once it becomes a group, I can select my object in blue, but I lose my dotted blue surfaces, and when I select my push/pull tool the whole object I just selected no longer has a blue border. Totally weird. It works perfectly fine if I don’t group it.


#9

Be aware there is a setting that contols pre-pick Push/Pull tool feature:

Window (menu) > Preferences (menuitem) > Drawing (panel) > Miscellaneous (group)
control: Disable pre-pick on Push/Pull Tool (checkbox)


#10

Thank you!! yes, that was it! It’s working now. Thanks so much