Push-pull not working for windows, walls are parallel


#1

Hi,

I’ve been getting intermittent odd behaviour with the push-pull tool when creating windows, hoping there’s something obvious i’ve done wrong with my model. I can’t make windows at all now, and i’m getting a strange flickering. Pretty frustrating as I just rebuilt the whole thing for precisely the same reason, but realised my walls were not parallel last time. Now i’m really stumped!

Thanks in advance :slightly_smiling:
Windows push pull problem.skp (741.7 KB)


#2

Is this what you are trying to do? For the first opening I clicked on the window face and then the back edge of the wall. For the small window, I double clicked on the window face.

I would say your walls are parallel this time. :wink:


#3

Hi Dave, Thanks for getting back so quick! I’ve actually managed to get a few of them to work (including those ones on the back wall) but i cant get the long window on the ‘Western’ wall to go. When i run guidelines over they dont intersect, so they must be slightly out but i can’t see where.
Basically I drew the floor plan, extruded with push pull, then added extruded faces at the correct heights with the exact same dimensions for the underfloor structures and the roof, then sandwiched it all together. Is there a better way to do this? It seems to be giving me troubles. I cant get the row of windows at the front either (which i think might be a different issue).

Thanks heaps for your help :slight_smile:


#4

The long ones are grouped. Explode them and they will intersect with the wall geometry.


#5

They were indeed, thanks box. Still stumped on this West wall, still a bit unsure how to put the structure together so this doesn’t keep happening.

Cheers.


#6

I’m in the pub now so can’t look at your file for a while.


#7

No worries, enjoy that pint! I suspect the few I had earlier this evening have not helped by skills any


#8

The one on the west wall is not parallel to the wall. This accounts for the flicker you’re seeing. I moved the window out away from the wall and added dimensions from the top corners to the wall. Notice that the dimensions are different. My guess is you copied and rotated a window you’d drawn on another face. This lack of parallelism would account for the problem you’re experiencing.

By the way, you probably be working with precision set higher than you have it and turn off length snapping. You may not want dimensions to 4 or 5 places beyond the decimal but while you are drawing, having the precision set that high will make it possible for you to identify problems like this. You can change the precision when it comes time to add dimensions if you need to do that.


#9

Hi Dave, Thanks for your advice that is really helpful. I have changed the accuracy to 4 decimal places and turned off length snapping. Unfortunately, I did actually measure and draw the window off that wall, and whenever I do it again the guides don’t intersect, which leads me to believe not all parts of the face are parallel (it is made up of the extruded walls, extruded floor, and extruded roof sandwiched together). I guess because I had length snapping on to inadequate accuracy, these aren’t quire parallel. Is there a way/command to ‘make parallel’ really close measurements? I really wanted to avoid redrawing the whole model again.

Thanks again!


#10

I hadn’t checked the corners to make sure they are vertical. They aren’t as you can see by the dimension in the screen shot. So the wall slopes slightly to the outside although it does appear to be parallel to to the green axis and the window isn’t parallel to the green axis.

I think you could fix it but making sure it is all straightened out is probably more work than starting from scratch. You might delete all but the top of the walls and use Push/Pull to push down new walls. If the top face is parallel to the ground plane, that should get you a long way to better walls.

You probably ought to be using groups or components better than you are, too.


#11

Thanks Dave. Man this is so frustrating, that is 2 days i’ve spent making models that I just go ahead and delete :frowning: I don’t really understand why the dimensions aren’t perfect as I entered them numerically when they were built. So if i rebuilt everything with length snapping turned off and accuracy with units to 4 decimals, will everything be precise when I enter the dimensions numerically? I must admit I find groups very confusing as well, as it seems push/pull only works when things are exploded, but then I run into all kinds of trouble re-selecting only what I want to select.

Thanks so much for your time, much appreciated!


#12

Will it be perfect? I don’t know. A lot of that depends on you and how you draw the things you’re drawing. You have to make sure you’re drawing on axis and make sure you aren’t moving edges or endpoints inadvertently.

As for the group thing, It’s imperative that you learn to work with groups and components. They are the only way to keep geometry separated from other things. As you can see, I unhid the ground or whatever that’s supposed to be under your building. It is part of the building because it’s all loose geometry. You’d have a difficult time if you want to move the building around that face.

You do not have to explode a group or component to make modifications such as extruding with Push/Pull. You can edit the group or component to open its wrapper and make the modifications. I would suggest that before you even start drawing the building again, you spend some time with the video tutorials at sketchup.com.


#13

Thanks Dave, I have been watching lots of videos but it seems i’m a bit slow :frowning: I generally do group things, but when I was getting frustrated with that window I exploded everything in case that was the problem. One thing I found hard with push-pull inside the group wrapper is that surrounding inferences are lost, ie when I was making the pergola and had to extrude the bearers out to meet the uprights. Is there a way to show surrounding geometry when inside the group wrapper?

It seems all the other wall dimensions are correct, but i will probably start from scratch to be sure. So before I begin again, is the issue likely to be that the underfloor and roof extrusions were slightly different sizes to the floorplan extrusion because of length snapping/inadequate decimal accuracy? Was it silly to create them as separate extrusions and sandwich? I think i’ll make it a bit differently this time - ie extrude the walls and floor level up from the same rectangle. Thanks!


#14

As far as references outside the component or group, you should be able to see them just fine. I opened a group in your model (it was buried pretty deep within other groups) and you can still see the rest of the model.

I guess I can’t say what caused the errors in dimensions. I don’t know what order you drew things in. I would start with the floor plan and extrude the walls up. Then make the walls a component or group (my preference is for components) and then add in the “stumps” and the other parts.

You need to learn about how to do efficient nesting of components/groups, too.


For example there’s no reason to have three group wrappers around this beam. One is enough. More just makes it harder to get at the geometry within if you need to make changes to it.


#15

Thanks Dave, i’ll definitely take a look at grouping more effectively, I hadn’t been using the parent/child nesting dialogue shown in your reply, which would make it nice and clean. Just one more question! Intuitively I thought keeping accuracy at 1mm would be good as it would prevent smaller increments (and the kind of minute size differences that were the problem in my model) by snapping to 1mm. Obviously i really don’t want any measurements smaller than 1mm, is there a way to ‘snap to 1mm’ and would this be desirable, or am I misunderstanding this completely? Cheers


#16

You can enable length snapping but I find it gets in the way most of the time. By keeping precision high (a number of places right of the decimal) you can still draw at dimensions in 1 mm increments but when things are off, you can actually see it. If Precision is set coarsely, you can’t see those errors.


#17

Thanks Dave, this all makes a lot more sense now. I’m now much more organised with groups and components. I’m wondering if you work with dimensions showing much of the time? I ran a ruby code that includes a hide/show dimensions item in the view menu which is helpful. Also, one advantage of groups over components appears to be the inclusion of dimensions as an element, is this something you consider when deciding whether to make an object a group or component?


#18

Hi Dave,

Thanks for all your help so far, i’m sure you’re tired of my questions by now :grimacing: So ive regenerated the model from scratch with a much neater outline as suggested - much better - but i still cant get the windows to push through! I’m really stumped this time, any ideas? Its possible my graphics card is being a bit weird - its only the integrated chip on a 13"MBP.

Cheers,
Matt3 Bedroom.skp (734.0 KB)


#19

You have to understand context.
If you want geometry to cut through other geometry it needs to be touching. When you wrap something in a group or component it separates the geometry so it doesn’t stick to or cut other geometry.
So, to cut a hole in a wall for a window you need to be inside the group, so open the wall group for editing (double click or right click and select open for edit) and draw the rectangle on the actual surface of the wall and push it though.
You can then exit the wall group and place a window group in the hole.
Wherever I say group it could also be a component.