Push/Pull cannot cut through object


#1

Hello dream team,

I’m fairly new to Sktechup (although previos experience with other 3d modelling) and seem to run in to the same problem over and over again. After three days of searching for a solution both here in the forum and on Google I really need some guidance…

I’m trying to sketch a house with both interior and exterior. When pushing a rectanle shape (window) through a wall, the action sometimes does not cut through completely, but leaves a thin solid shape left in the hole. The rectangle is pushed the same distance as the wall is thick though. I’ve also tried to pull to the surface on the other side of the wall leaving the same bad result. Obviously I’ve done something wrong and most likely something stupidly easy, but cannot seem to find a difference in my actions when it works and when it doesn’t. As far as I can see all shapes are planar.

. First I drew the shape of the ground floor and drew the walls onto that (2d top view). Then I pulled the walls up followed by the push action to cut out windows. All help or guidance is much appreciated, thanks! In the attached drawing the orange wall is the cause of three nights bad sleep…Sketch gone bad.skp (2.0 MB)


#2

The first thing you need to do is read this…
Does SketchUp Support Layers? — SketchUp Help


Next
There are 105 Materials and 23 Styles in the model file.
Learn to Purge the file … Window > Model Info > Statistics > Purge Unused


Yes, it all looks good!


Aidan Chopra explains the way things work…


#3

As well as reiterating everything that @Geo said…
Look at your Model Info > Units settings,
Un-check the ‘enable length snapping’ option - which is also set at 1.00m increments !
This is what is causing issues on some walls etc when PushPulling etc.
It will make your modeling a more pleasurable experience…
I also suggest that setting it to 3 d.p. would be more logical, e.g. 1.000m, as you will sometimes work to parts of a cm, e.g. 2.5cm >>> 0.025m


#4

Alwe,
It appears that the wall is not exactly .19m thick. (If you use the tape tool, and measure the thickness of the wall, it will show a “~” symbol before the dimension. This is telling me this is as accurate of a dimension as the program will read out based on your preferences.

I’m guessing that you are selecting a face (rectangle) drawn on the orange wall and push/ pulling it .19m, by typing in this distance. Instead adjust the wall so it is exactly .19m, and then trying this operation or select the face >> push/ pull >> then inference the opposite wall either on the face, an edge or corner. Both of these methods worked for me, with out any issue.

If the wall thickness should be .19m adjust it using a guide and the push/pull tool.

If the wall thickness is currently correct, then use the second operation to successfully punch the hole in.

I do have to agree with TIG, your preferences do not seem to be optimized for what you are modeling. I suggest you play with these and see what will allow you the best results for your workflow.

Hope this helps.


#7

You’re just awsome @spmcgill81, @Geo and @TIG!

Helped solve the problem since the wall was not exactly .19 m thick.

Grerat and helful tip!

Awsome! Have played around with the setting and it saved a lot of frustration. Thanks!

The inprecise thickness together with my method was causing the problems. A bit suprised since the wall was created with a guide that should have been exactly .19 away from the parallell wall. can very well be related to what @TIG pointed out.

Again, what a wonderful welcome to the community! Thank you guys!