Problems putting on roof

Continuing the discussion from Medeek Truss:

I have a problem with Medeek Truss. The trussroof places 90 degrees onthe floorlevel and is not a group? Where do I go wrong?
MedeekTruss2024-06-21_11-25-49

What version of medeek truss are you using?

1 Like

I can’t speak to the 90 degree rotation, but I’ve found the “truss on the floor” problem is solved if you toggle the “Adv. Roof Options” to “On,” even if you don’t change any of the advanced roof options

2 Likes

First make sure you have the latest version of the plugin.

Then turn on the Ruby console in SketchUp, duplicate the error, and post the error codes or email them to me.

When you see the assembly being created at the origin of the model and it is ungrouped and rotated or translated out of position this is an immediate sign that something has gone wrong. The plugin has aborted the draw process mid-draw and has simply aborted and abandoned the geometry at the origin where it initially creates the geometry.

By giving me the error codes I can immediately tell where the error occurred and usually within a short time figure out what is causing that error and either fix a bug or tell you what is being done incorrectly.

1 Like

Also what version of SketchUp do you have installed?

Are your axes set to an orientation other than the default when opening a new document? It does stuff like that if the axes have been changed.

2 Likes

I don’t think the axis is the issue here, based on the trusses being dropped down at the origin. However, I do need those error codes to understand what is causing the error.

Also, make sure you have the latest version of the plugin, I just released an update which addresses a bug that was introduced about four versions ago.

Version is 3.5.4 used with SketchUp 2024

Justin was right! Turning on “advanced Roof Option” solved it. Even if I turn it off again ; )

MedeekTruss2024Solved-06-21_11-25-49

Thank you Justin : )

3 Likes

…BTW, -Roof tiles would be nice in “Advanced Options”, -I guess 3D tiles would be hard to obtain…

1 Like

If you turn off the advanced options and the restart SketchUp does the error happen again?

If so can you turn on the ruby console and then post or send me the error code.

I’m going to see if I can duplicate this error on my end.

Yeah it happens again. How/where do I find the ruby console?
…never done before.

it’s in the extension menu, at the top, the developper tools.

1 Like

In the Extensions menu, click the Developer Tools, then you will see the Ruby Console.

Once you have it open then duplicate the error and then send or post all of the error codes generated. I will take it from there.

I’ve located the issue and should be rolling out an update a bit later tonight, please download this latest updated version tomorrow and let me know what you get.

Yes, turning off the advanced options causes the problem since my code for the hidden geom being generated was relying on a variable being initialized in the advanced options, we had the cart before the horse, so to speak.

P.S.
Introducing the hidden geometry so that I could merge roofs was a bit of a Pandora’s Box. The end result was worth all the work but the code is complex enough that there are a lot of possible states that all need to be checked. Inevitably I always miss a few and since I usually operate the plugin in “full feature” mode its easy to overlook the more trivial cases.

1 Like

I am missing some parts on my roofconstruction…

CC BY-SA

Bilde: Kjell Brørs

It’s a verge.
The vertical part is a barge-board, or verge-board.
The top part has no common name, but could be called a verge-cap… or something similar…

ok. thank you. Do I find a these parts in the truss plugin?

The barge board is part of the included options but not the barge cap.

Reason asking is sometimes it is double or even triple to cover up construction …


It would also be nice to have the option to choose your own roof texture (roof tile) in the plugin. When you edit, the texture goes back to your original plugin choice.

1 Like