Problems mapping materials to imported ACAD model in sketchup 2018


#1

new problem when i upgraded to 2018: autocad models will not accept materials without exploding every item. an ideas how to avoid this?


#2

Can you post an example SKP file that shows this? Make it before exploding.


#3

hmmm I was just reading about some issues importing ACAD files into other programs and issues with reversed mapping normals. Or is it a scaling issue?


#4

test1.skp (220.1 KB)


#5

Are you opening the components for editing before trying to apply materials? There should be no reason to explode the components to add materials.

What face style are you using?

One thing I notice is incorrect use of layers. Not sure if this is due to the import or not but all edges and faces should be on Layer 0. In your model, they aren’t. It’s easily fixed by reassigning the geometry to Layer 0, though.


#6

why should they be on one layer? i have separate layers in autocad


#7

Layers in SketchUp are not like layers in AutoCAD. Read the help files on using Layers in SketchUp.

https://help.sketchup.com/en/article/3000122


#8

i don’t know about face style.

yes if i open the object by double clicking it i can map materials. in older versions though i didn’t have to open the component. i could just map materials in one move


#9

ok. will do. thanks!


#10

You have no control over the orientation of the materials if you apply them to the component containers instead of the faces.

The faces in the components in your model already have a material applied to them which will override materials applied to the component containers. This is not new in SU2018. It’s always been that way.

If you repaint the faces inside the component with the default material, you can then paint the container if you want to do that and have it show.


#11

ok. thank you


#12

I have the same problem. Even if I double click it, it still only maps one face at a time. I do very simple mass models and I used to be able to just click each mass and all faces would map the same, with one click. No I have to click each face. This is very time consuming if you are testing colors or if you have a radius.

Help?

I have found a work around in that I import it into a 2017 or older version of sketch up then just open it in 2018 and it works as normal. I’d like to skip that step if I could.


#13

Problem Solved

It appears that sketchup now assigns a default material as it imports. That prevents simple mapping because it already has a material applied.

All I had to do is erase the “1” material created in autocad and it asked if I wanted to replace it with the default material. Problem solved.


#14

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.