Attaching materials in 2018 on models imported from Autocad


#1

I have been importing simple autocad models into sketch up for many years. Moving to 2018, suddenly mapping materials on the simple solids does not work. In order to map the surfaces, I have to explode the model and map each face, sometimes each side of the face. This is very time consuming and I am wondering if I am missing something. A work around was to have an older version of sketchup import the model and then work on it in 2018. Problem is I no longer have access to the older version of sketchup. Any help would be appreciated.


#2

Yes, in SU 2018 the import function has ‘improved’ and no longer seem to ignore images or some other features when importing from Autocad. The import menu does not offer any settings for this.

Could it be that the seperate faces in your model now have a specific material from Autocad assigned?
If you paint your model, the material only shows on surfaces that have the default material assigned.
So you should be able to solve this by opening your model, then select all the entities and paint to default.

I hope this will work for you…


#3

Awesome, that was the ticket. Thank you so much. All I had to do is erase the " 1" material created in autocad and it asked if I wanted to replace it with the default material. Problem solved.


#4

Hey,
I had the same problem, thanks, for you help


#5

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.