Import from AutoCad 2018

Hello!
I did the following in sketchup 2016 and I never had a problem. Now in Sketchup 2019, when I import a document from AutoCAD, it arrives completely with the particular colors that I presume to correspond to the materials types defined in autocad. I work with modulars, and the program (Giza 2020) gives me the option of lifting them in 3d and then exporting them to the sketchup. In sketchup 2019 this import looks like the image, and if I want to change them in color I have to enter each component to fix it (it is not good because there are always lines that are not painted). How can I make it matter completely white and easy to paint?:disappointed:
image

Three things to try:

  1. Check to see if ‘import materials’ was checked in the options when you import your DWG/DXF

  1. My model didn’t import materials but did bring colored faces from CAD’s layer colors. So you can deleted these in the Materials Browser under ‘List/Delete all materials’ *Edit - this may be Mac only as the materials work a bit differently between mac and PC.


  1. Or, if you want to use an extension to do it, Materials Tools lets you remove materials from just selected components and other options:


I love your quick response.

The # 1 had already tried and had not worked.

only # 2 worked, THANK YOU! the only thing different is that I had to erase each material, one at a time. But that’s the least, because it solves the problem of colors and painting completely without seeing the lines of strange colors

The # 3 did not know where to find it.

THANK YOU!

You’re welcome - here is Materials Tools - https://extensions.sketchup.com/en/content/material-tools FYI it requires a companion extension to work - https://extensions.sketchup.com/en/content/tt_lib²

I didn’t realize it was an extension (although you clearly wrote it)
Thanks again! I install it and it’s much faster that way

1 Like