DWG Import Colors - Don't Want Them

Hello everyone,

I am an architect, using Sketchup to create visuals for a client. Starting with a 3D view in Revit (2018.3 if it matters), I export to DWG 2010, then import that to SketchUp 2019 Pro. The imports in 2019 come in colored rather than with the default material applied. It’s particularly painful because it applies the randomly colored material to the front and the reverse face of all objects, so even when I have everything selected, I have to go ‘inside’ my walls to apply the default material to the reverse face as well as the obverse face. Since I’m importing something that has subcomponents, and maintaining them as subcomponents is useful to me, I also then have to go into every single subcomponent and apply the default material to both sides of the faces as well. This gives me no benefit, and adds noticeable time to my workflow.

Is there any way to apply the default materials to everything on import like it did in all previous editions? This new “feature” occurs regardless of whether I have the “Import Materials” checkbox ticked on the import options.

Thank you.

You could delete all the materials and you will remain with the default materials for faces (white/blue).

Interesting workaround, thank you. I just gave it a try on a smaller model and it’s definitely a LOT faster than what I’ve been doing. Not AS easy to do with a model that’s already got materials in it I want to maintain (like on other objects in the sketchup file), but I can always import the DWG into its own file, delete all materials, then copy it into the file I actually want it in.

So yeah - VERY much appreciate that improvement, but still I’d rather just not have the materials applied in the first place, if there’s a way to do that. =)

Use the same color for every layer in your DWG file, or put all geometry on layer 0, then import it to SketchUp.

Not sure this is a new feature.
Have you considered removing the material from you original before importing it.

I think if I use the same color for every layer in my DWG, it will still apply a colored material to it in SketchUp (rather than the default material). I’m not sure the process of doing that or putting all geometry on layer 0 is faster than what you already suggested.

Well… it didn’t happen before I upgraded to SketchUp 2019. I’ve followed this same workflow a lot of times in multiple previous versions of both SketchUp and Revit without the DWG import coming in with colors.

In response to your question - the materials being imported are not related to my original. They relate to the layers in the CAD file from what I can tell (Eg. all windows are one color, all doors a different color, etc) whether I have different materials applied to them in Revit or not. Plus removing the materials from my Revit file (even if that were associated) would take at least as long if not longer than clicking through in SketchUp. See above reply in regards to homogenizing material or layers in CAD before import. Don’t think it would be faster than just deleting the automatically applied materials.

I was hoping I had missed a checkbox somewhere or something.

Ok, either I have it wrong or you do, I’m sure it’s me so I won’t bother you further.