Problem with Upright Extruder and SketchUp 2021?

Is there a problem with the Upright Extruder extension and SketchUp 2021?

I was doing a quick model of a 2mm pitch lead screw for an illustration … and planned to use the Upright Extruder … but I had to go back to SketchUp 2020 to finish the job.

Here is the 2020 .skp file … the one where the Upright Extruder worked.

211114A_2mm_Pitch_Lead_Screw.skp (118.4 KB)

And here is the 2021 .skp file … all set up to “Upright Extrude” with the lead screw “section/profile” and the 2mm pitch path. But I could not get the Upright Extruder extension to work … no error message … no hanging up … nothing.

211114C_2mm_Pitch_Lead_Screw.skp (3.8 MB)

FYI … both files are scaled 100X.

And then one last question: After years of purchasing the latest version of SketchUp each year I am now being “forced” to move to a SketchUp Pro subscription (and will have to do that before December 4th). This has already been discussed ad nauseum on this forum … so I do not want to rehash any of that … except for this question about extensions:

Extensions are touted as one of the distinctives that differentiates SketchUp from some of the other tool sets … and I agree. Even though I typically only use “native” SketchUp … I find some extensions are exceedingly useful … so when/if an extension does not work, it is real problem.

So, here’s my question: As SketchUp Pro evolves what is the plan to ensure that extensions continue to deliver the intended functionality? If the functionality of an extension shows up in the native tool set … then there may not be a problem. But for a functionality to disappear … as it appears to have happened with SketchUp 2021 and the Upright Extruder extension … that’s a problem.

You seem to have mixed the models up, A is the one set up to go and C is the complete one.
But I had no issue using Upright Extruder in 2021 with your preset up model.

I’ve modeled quite a lot of screws in SketchUp 2021 with Upright Extruder and never had a problem. Latest one here:

There’s a lot of geometry to process so it can take a little time but it works. It would help to use a “fast” style. That will speed up the process considerably. This is in real time.
I turned off Profiles in the style. Profiles add work.

If I were modeling a 2mm screw I would model it at 2 meters (scaled up by 1000x). With units set to meters there’s no moving the decimal when entering dimensions. I did the same thing when modeling the clamp head. It’s dimensions were given in fractional inches. The main screw is specified as 7/8 in. dia. so i drew it as 7/8 meters in diameter. Easy to resize later when the modeling is complete if you have to do it.

Here’s the screw from your A version. I went ahead and made it a solid component.

211114A_2mm_Pitch_Lead_Screw.skp (232.8 KB)

As for your question regarding extensions being kept up to date to keep up with new versions of SketchUp, that’s strictly up to the authors of the extensions. Most extension authors do seem to update their extensions when needed but there have been some that for one reason or another decided they were no longer interested in supporting their extensions.

I have a handful of extensions and plugins that haven’t been updated in more than a decade. They still work in the current version of SketchUp. The authors have either lost interest in keeping them up to date or in a couple of cases the authors shuffled off this mortal coil. If there comes a day that those tools no longer work, I’ll find a different tool.

Except that functionality has not disappeared in Upright Extruder.

Appreciate you and Box taking the time to look at this and respond. Obviously Upright Extruder works under SketchUp 2021 for you guys.

Regardless, Upright Extruder is still not working on my machine … under SketchUp 2021 - Version 21.1.332 … even after reloading it.

Another possible difference is that on SketchUp 2021 on my machine the Upright Extruder “controls” show up under the “JHS Toolbar.” Might that be the problem?

Yes there is an icon for upright extruder in the JHS Powerbar. This may be an older version. This is the toolbar with the version I have:

1 Like

I’ve never found any use for the JHS Toolbar so I don’t have it installed. It might be your problem though. I have the same toolbar @RLGL shows but have it turned to vertical. It normally lives on the left side toolbar area.

It could be that the JHS Powerbar extension doesn’t have the latest version. That would be up to the author of the JHS Powerbar to update.

Best I can tell … the icons for the Upright Extruder in the JHS Toolbar have quit working on my machine.

When I removed them from the JHS Toolbar … and used the Upright Extruder “manually” it worked. I made NO changes to the SketchUp model.

Cantact the author of the JHS Powerbar and ask him to update his extension. Or perhaps you can manually do it yourself.