Problem with solid being turned into a group

I’m not sure if this is a technical problem or not, but it’s something I run into quite frequently.
With the model attached, subtract the red solid from the black solid (railing). Switch to monochrome view, and examine the upper surface of the remaining railing, which is now a group. You will notice sections of the surface that are now open. Why is this happening, and can it be avoided?
Spiral Staircase.skp (1.5 MB)

On my phone so can’t look at your model now, but most likely it is due to SketchUp’s small faces behavior. You can search the forum for a great many topics discussing it.

@slbaumgartner in on the ball here. Looks like a tiny face issue, the facets in your railing are very small. Scale the whole staircase up by a factor of 10, perform the subtract and scale it back down. Or research the “Dave Method” of leveraging components to edit the original in place.

Both solids you are working with, railing included, are starting out as groups. Native Solid Tools turns all components into groups when used. Other options like Eneroth Solid Tools keep elements as components.

The scale by a factor of 10 worked perfectly. Someday, from a technical aspect, I’d like to understand why at one size the subtract function fails, and why at a magnitude of 10 it works. I have to wonder if there is a roundoff or some sort of precision issue involved. A solid by any magnitude is a solid when edited properly, unless a rounding issue develops at certain sizes.

Yes, SketchUp’s minimum resolution is roughly .001”. Nodes in the mesh closer than that start to get resolved into single points which disrupts the mesh and causes holes and errors. So if you are performing an operation that creates tiny faces then the operation will fail, up the scale and the operation will succeed. Faces of a very small size can exist within SketchUp, even if creating them at that same size would cause an error. So once geometry is made at a larger scale it can be “shrunk” without error and can exist in the model.

A solid in SketchUp is a single watertight surface mesh with an inside and an outside, no holes, and every edge touching exactly 2 faces. The size of the solid component has little to do with it, what matters is the size of the faces in the mesh. So a very tiny cube might subtract fine from another as each face is an uninterrupted surface. But your relatively large railing fails because there are so many facets in the circle you used to build the railing, so the railing has tons of tiny faces in its surface.

1 Like

The minimum resolution explanation is what I suspected, and what I was looking for. Thank you.

You’re welcome, It’s a bit of an oversimplification, SketchUp can support much finer resolution than .001” but effectively that’s how it behaves.