Problem with refractive IOR V-ray

v-ray

#1

Hello everyone, first post here.
This is a Vray problem but I hope you don’t mind :slight_smile:
I have an annoying problem that’s been bugging me for the last nine hours and I don’t know what to do. I have these glass tubes, 10cm thick and I’m trying to get them to be transparent for the reflective sea, however, after going through three layers of glass, they are no longer able to transmit the reflectivness of the sea and only the diffuse. If I increase the ‘Max trace depth’ in the advanced section of the render options from 5 to 15 (wich I believe is the option that controls how many reflections/refractions one lightray is calculated) I can finally sea the beautiful turquoise sea even through as many as six layers of glass, with one caveat. The IOR is basically useless and doesn’t do anything, as if it was stuck on 1. I have tried everything and really don’t know what to do next. Any help would be much appreciated.


Both have the same refractive IOR of 1.35, the only difference is that the one without any visible distortion has Max Trace Depth set to 15 instead of the default 5.


#2

I wonder if V-Ray thinks your glass arch is a solid piece of glass. In Twilight, there’s an architectural glass preset and a glass preset. The glass preset is for solid glass and the architectural glass is for windows and stuff, but it makes a huge difference in opacity. Is there something similar in V-Ray?


#3

Two way mirror issue of light levels ?


#4

Hello thanks for quick reply!
Not that I know of, vray has alot of premade materials and this is regular glass.


#5

I tried turning off reflections completely and only have refractions but to no avail :confused:


#6

The IOR is an exact value that you should look up for each material. Although, the default glass IOR is probably accurate.

List of IOR values:

The index of refraction refers to the angle that light propagates through a surface. It is a different thing than the amount of refraction you see.

svg

The thickness of the tube changes it’s amount of refraction:

Also, it’s very important to orient your front faces outwards before rendering (even in V-Ray).

Does that solve your problem?


#7

Do you have 3 layers of 10 cm thick glass (total of 30 cm)?

According to Vray Docs:

Max Trace Depth – Specifies the level to which all bounces that will be computed for reflections and refractions are clamped.

You seem to solve your problem via max trace depth , what is the caveat/problem?


Also here is the text that displays when you hover over ‘Max Trace Depth’ option:

So i assume when you increase this parameter, it overrides/surpasses IOR settings.


#8

Wow! Thank you for your time and dedication in replying, I did not know about the back/front face importance, will try and report back!


#9

Thank you so much for your reply! Yes three or more layers depending on where I am in the scene, up to six, 10cm thick each. But it seems that reflections can only go through 2 layers of glass.

The problem with Max trace depth is that if I increase to say 15, I can see reflections through more than two layers of glass but the ior on the refraction is locked at 1, not physically, it just doesent matter what I enter. And even worse, sometimes even if I return to the exact original settings, the refraction IOR is still bugged and I have to restart sketchup from an earlier save.


#10

It turns out the faces were facing the correct way so it was not that.


#11

Do you think it might not be the amount of layers but maby the combined thickness?
I will try several thinner layers tomorrow! :smiley:


#12

I would try 1 layer with 30 cm thickness as well, making 3 layer might be multiplying refracting effect triple times which is not giving desired result.


#13

Is there a reflection opacity setting ? This would be equivalent to light settings within and without.
With Doppler combined with refraction you can get interesting lense flares too. Most use fade to black for depth perspective however. If the issue was thickness and number of layers there would be more reflections dependant on albedo and light intensity of reflected light source. Intensity at reflective surface would cause multiple reflections visible other than in light occluded locations.


#14

It doesn’t seem to be a thickness problem , but a layer. I put up 1cm thick pieces of glass in layers of two up to six and the first two were transparent for reflections with Max trace depth set to 5, three layers with Max trace depth set to 7, four layers MTD set to 9 and continuing plus two for every peice of glass.
However, this was for Max Trace Depth in the Raytrace advanced options, it didn’t make any difference if I adjusted the Max depth in the material itself which is strange.


Max Trace Depth disabled

Max Trace Depth 7

Max Trace Depth 9

Max Trace Depth 11

Max Trace Depth 13

The problem is that the refractive IOR is completely unresponsive and seamingly put at 1 when I enable Max trace Depth, no matter what I enter it wont make a difference.


#15

Did you read my last paragraph in 7. reply?


#16

I can’t enter the link you provided, it says it’s private but I assume you mean

"Also here is the text that displays when you hover over ‘Max Trace Depth’ option:

max_trace_depth.jpg
847x48 17.6 KB

So i assume when you increase this parameter, it overrides/surpasses IOR settings."

Well it should not affect the IOR at all one would think, only the amount of times the ray of light can enter and exit a transparent object such as glass.


#17

However, for some reason now everything works as it should. I have no idea why.
(Don’t mind the sea, I have not turned on dipslacement and caustics)


Max trace depth disabled


Max Trace Depth 15

I have no idea why the refractive IOR is suddenly working even with Max Trace Depth enabled.


#18

I’m not really sure at this point you may be right, my assumption might be false. I think only Vray developers can give you a straight answer to this (It might be just a bug). Try asking them: V-Ray for SketchUp forums


#19

It does seem so, I will ask there.
Many thanks! :slight_smile:


#20

Hello everyone !
actually there is no Extensions command in my sketch up
somebody help me