Problem to transfer a 3D model of a real object in SketchUp

Hello, I currently have a project which consists in modeling a real object and introducing it into a virtual scene. To do this, I chose Recap Phto for 3D modeling. Then, after creating the modeling, I send the modeling file in 3DS Max in order to have a .3DS file to be compatible with sketchup. After doing this, I try to import this modeling into my virtual scene on sketchup, however I have a problem that appears and I cannot solve it (see attached).
Would it be possible for you to help me solve this problem because I find myself stuck in my project?

Try to import the file using Skimp or Transmutr.

You could also export directly from Recap Photo in OBJ or FBX format, and import that file into SketchUp, using one of the two recommended extensions. This way you no longer need to use 3DS Max.

You can’t directly import FBX or OBJ files natively into SU. These are the supported file types in 2020.

There’s a paid for plugin from SimLab with a short free trial to import OBJ files, which I have used successfully, SimLab OBJ Importer.

I have no experience importing FBX files. Try searching this forum for “FBX import”. You’ll find over 50 topics.

I don’t understand, I already tried to import directly into Sketchup the modeling done on Recap Photo but it is impossible. Sketchup does not accept FBX or OBJ formats (see attached).

I completed the explanation and outlined what was most important.

Have you looked at those two extensions?



1 Like

You could also try the new Universal Importer.

Thank you for all your answers. I chose Universal Importer, it is very easy to use. However, once the import is done, I end up with this (see attached) while theoretically it is supposed to be a bluetooth jbl red speaker. How can I make the modeling appear without problem?

I found the solution on my own, however I am facing a new problem. When I am far enough from the enclosure, it appears all black. I have to get very close to see the real colors of the modeling. How is it done and can we solve it?Capture

Turn off hidden geometry and soften edges.

Might run CleanUp 3 on it, too.

Turn off edges but leave on profiles might look nice.

where can I do that?

I cleaned with cleanup but it doesn’t change anything

In the View menu, Edge Styles. Uncheck Edges.

It would be worth trying Skimp. If you can post the model so far I can show you what Skimp could do with it.

Interesting project, but by taking a couple of measurements you can model that object in SketchUp directly in minutes, in a much shorter time than it takes to clean up this mess.


Most certainly yes, but that’s not the goal of my project;)

I cannot put an OBJ or FBX file on the forum.

I meant the SketchUp version of your model.

I have Sketchup 2020. I don’t understand what you want to do