Problem opening file

Can anyone open this file successfully? It looks as if it will open but on my Mac I then just get the beachball of death and can do no more. I have to Force Quit SU to get out of the loop.

It’s an export from a Tekla file and says it uses SU 8 (!). Could that have a bearing?

The file is over 30Mb so here is a link: https://www.dropbox.com/s/y69oey8lvhoiu76/SCWS%20DOCKING%20190619.skp?dl=0

I sent you the file saved in SU2017

It opened for me in SU2019 on Windows.

The model’s going to be a pain in the neck. All the faces are reversed.

Simon, first I opened in SU Viewer, to see if it was possible on my mac and it took a little time…

based on that I imported it into a new model with a fast style and all inspectors closed…

didn’t take [beachball] too long, but is slow to navigate…

john

John, what fast style did you use? I notice that you are still on El Capitan and I think my move to Mojave may have been a mistake. All sorts of applications are reporting problems now. Almost like the new OSX was designed to disable older Macs. As if!

Don’t know if these reports tell anyone more tech savvy than me anything useful.

22 06

I’m also using Mojave, without issues that I would attribute to that. My MBP is now 7 years old, so I guess it depends on what you mean by “older Macs”.

But anyway, regarding this model:

When I opened it I got the dialog about needing to fix errors. If I said fix later, the model took forever to load while consumed a steadily increasing amount of memory. In your screenshot you can see SketchUp using almost 6GB of memory, which is completely unreasonable for a model of this level of complexity. If I let SU fix the errors, it loaded in a reasonable amount of time using a more sensible amount of memory.

Once it was open, I noticed various issues with the model.

This looks to me like the Tekla exporter was written with a very poor understanding of SketchUp and how to use it’s features efficiently (and maybe hasn’t been touched in a long time if it exports SU version 8!). Perhaps some of the inefficiency was present in the source model and just carried over.

Among the issues I see:

  • As @john_drivenupthewall noted, it is slow to navigate, particularly when the larger structure is visible and not zoomed in closer. As he also noted, it doesn’t use a fast style, which also impedes response, though not as much.
  • The model has 688037 edges and 278423 faces, putting it into the pretty heavy but not world record level. It is going to strain any but a relatively powerful computer.
  • The model contents are located too far from the origin, for no evident purpose. I wonder, was this extracted from a model with more content adjacent to what’s now present?
  • as @DaveR noted, all the faces are reversed
  • the model contains large numbers of distinct components with one copy each, even though they look identical to me. For example, look at the various bolt_array components. This thing is going to kill the outliner and the component browser! Failure to use components for identical parts is bloating the file size.
  • the components have their origins located far from their contents

I can also see some dubious structures in the model, such as gaps between members, but those were surely present in the original.

1 Like

Steve, thanks for such a detailed response.

My computer is the same age as yours, which is interesting, maybe even a bit younger.

I never got a dialog about fixing errors so I didn’t even get an option to correct things. Why would that be?

I don’t really know anything about Tekla. It’s software that some steel fabricators over here use. If you Google it and Sketchup, it looks like you can simply export to SU without problem. But some of the issue could be with the drafting of the original Tekla model. Not easy to know.

I closed as many other applications as I could and tried to reload, then left it for a while to see what would happen. The beachball does eventually disappear, but as soon as I try to interact in any way the ball comes back. It feels as if it is just too big a file for my system to handle.

Hold on a doggone moment chaps! I just revisited the Tekla webpage and what do I see but a Trimble logo top left! Something jolly funny here if different platforms under the Trimble umbrella won’t play nicely together, surely. Unless it is to do with the original drafting of course.

1 Like

This is indeed a problem. It is understandable to have each part to be identified for production services, but if the parts are the same, naming the instance would suffice. No need to generate thumbnails for each component would also benefit performance…

FWIW. Mepcontent, which was recently aquired by Trimble, has a great library of IFC4 objects, but SketchUp does not support IFC4 files…

https://www.mepcontent.com/en

#Need to go further, #industry, #constructabilty

I have now been sent a different version of the drawing which is half the size and imports as a 2014 SU file. But I still get the beachball.

Could there be something conflicting with my system in the file? I don’t understand how some of you with similar hardware and software to me can open the file but I can’t.

here’s the new file: https://www.dropbox.com/s/yarabw6wfukm8jh/SCWS%20DOCKING%20200619.skp?dl=0

Simon, this file is opens and performs quite well for me. Face orientation is correct although it is floating almost 80 meters up from the ground plane.

I purged unused stuff–lots of materials-- and about cut the file size in half again. It’s a shame about the way the parts are handled, though.

DropBox is playing up. Uploading the file to Trimble Connect for you, though.

Thanks Dave. I don’t use Connect regularly. Will I get some kind of notification when it has uploaded?

Do you think the size of the file lies with the drafting in Tekla or with the conversion process? Maybe it’s impossible to know at this end.

I fixed Drop Box so you don’t have to deal with a new thing. Here’s the file.

I’m not sure where the file size issue lies. Clearly with a large part of it in the latest file is materials. The file size could be smaller if like components were instances of the same definition instead of each being it’s own definition. I don’t know if that’s something the user can control or if it’s just the way the software is.

Must be something to do with my machine/setup. I’ve now had this file in three different versions, all in increasingly reduced size but exactly the same thing happens each time. There’s a conflict somewhere and the computer just goes into a demented loop. Great for someone with a thing for beachballs!

20

Simon, in SketchUp->Preferences->General have you checked the box for “Automatically check models for problems”? I have that checked for exactly this reason - it finds a whole bunch of faces with defective plane equations. After that fixup the model loads ok on my Mac with only an acceptable amount of beachballing. It is still sluggish due to the amount of geometry, but otherwise ok.

Steve, I do have that checked but no problems ever get reported. Here are my settings:

51

That’s interesting, Steve.

FWIW, it opens in SketchUp Shop and performs for me quite nicely, too.
tekla

@DaveR I presume that’s on your Windows computer? I speculate that the performance difference is due to newer CPU and GPU hardware. Otherwise I can’t see why a model would perform so differently on Windows vs macOS…

@simoncbevans I wonder if the “Automatically fix problems…” setting affects this. I don’t have that one checked because I like to control whether and when the fixes are applied.