Problem with opening ,skp file on Mac (Yosemite) OS X


#1

Hi all, very much a novice here so need this is very simple layman’s terms…

I am a humble 2D designer but I have been given a 3D model of a SketchUp Pro file created on a PC from a third party so that I can drop in some visuals that I have created for the model, which is all fine and good as I know how to do this!

My problem is that I cannot open the supplied file which is coming in at about 60mb but I can open a smaller ‘test’ file which is less than a 1mb.

I am running the latest version on my system (15.3.329) and I can open and create other files no problem. I have skimmed through some suggestions via this page (disk repairs etc but to no avail)

Any ideas would be most helpful. Thanks.


#2

Need more info! I can’t tell whether this is due to some defect in that specific file or an issue with your system or setup.

What exactly happens when you cannot open the file? Error messages? Just sits and “beachballs”? Crashes? What?

Have you tried opening the Ruby Console first to see if any messages are displayed there? Also, if you have plugins/extensions installed you should try disabling them since one of them may be choking on something in the file.

How much free memory does your Mac have before you try to open the file (open the Activity Monitor and see if it reports high memory pressure). How much free disk space do you have?

Finally, is it possible to post the file somewhere that others can check it out? 60MB may be bigger than allowed here, but perhaps on DropBox or something similar?


#3

The .skp file format is independent from the operating system (Windows, OS X) and obviously also independent from hardware (PC, Apple PC)

By what means did you get the file (email, usb drive)?
Can the copy that you received be opened again on another computer? It could be that the file has corrupted when transferring it (especially via USB), then you would just need a new copy.


#4

Sorry, the software crashes instantaneously… I am not in work now but I
will forward a WeTransfer link of the file first thing.

Appreciate your feedback, thanks.


#5

The vast majority of instantaneous crashes are due to ill-behaved plugins/extensions. Please try disabling all of them and see if you can then open the model.


#6

Thanks, I have asked the people who supplied the file to give me a list of their plug-ins, so hopefully this will sort.

In answer to the question raised about my system, I am using the latest Mac Pro with an FirePro graphics card, 3.5GHz 6 Core intel Xeon E5 processor and 16GB RAM, so the system is more than able to deal with the .SKP file in theory.


#7

Have you also checked out / disabled your plugins? Plugins can cause issues at runtime (all call methods in a way that is not stably implemented in SketchUp), but in my experience it is not so typical that this has consequences for saved files.
See here: Disabling ruby scripts


#8

Thanks for that, tried it but still crashed without opening.

I have spoken to the 3D designer and he says he has no plug0ins apart from their rendering package called ‘Thea’?

Any ideas?


#9

Here’s the link to the file via DropBox


#10

@timmartin2567
hi it’s crashing for me while loading one of the materials in the model…

it is possible it’s a ‘Thea’ modified material, but can’t tell for certain…
john


#11

I had once a corrupted image file (that loaded fine in many viewers/applications, but crashed some). If that is the case, we could try to remove, re-save and reload that image.

It opens fine in the Wine/Windows version of SketchUp. I only have no clue what exactly is causing the crash.

I tried to export the textures (via Ruby API) to validate the files, but all fail with “FILE_WRITE_FAILED_UNKNOWN”. I got all textures exported with Collada export. All the .jpg files validate with jpeginfo. There are two .png and one very small .psd texture which seems to be applied on many small faces.
PSD is not a typical output format one should use for textures, it’s Adobe’s proprietary format for graphics editing and to some extent supported by SketchUp, but since it includes a lot of more data than SketchUp uses and all the advanced file features that Adobe might add in new versions, I think there exists a little risk for incompatibility.
I saved a version of the file without the iphone2.psd. Can someone test whether it now opens without crash?


#12

nope… still crashes.


#13

I looked at the crash log from when I tried to open this file. I found that the crash is indeed in a function that is trying to load a texture image into memory, but unfortunately the log doesn’t tell what image was involved or exactly what was the issue. In case a Trimble developer is reading this topic, the top part of the crash report is consistently the following, and seems to say that the crash is due to a deliberate assertion failure that presumably traps a known error? Both the original and Aerilius’s modified versions fail with this same error report.

Process: SketchUp [4307]
Path: /Applications/SketchUp 2015/SketchUp.app/Contents/MacOS/SketchUp
Identifier: com.sketchup.SketchUp.2015
Version: 15.3 (15.3.329)
Code Type: X86-64 (Native)
Parent Process: ??? [1]
Responsible: SketchUp [4307]
User ID: 501

Date/Time: 2015-02-20 09:00:01.980 -0500
OS Version: Mac OS X 10.10.2 (14C109)
Report Version: 11
Anonymous UUID: A654DCDB-D50F-9014-FD55-CDFA84AD361A

Sleep/Wake UUID: 42702DEF-28E0-4A01-952E-93F2C342BCBE

Time Awake Since Boot: 12000 seconds
Time Since Wake: 1500 seconds

Crashed Thread: 0 Dispatch queue: com.apple.main-thread

Exception Type: EXC_CRASH (SIGABRT)
Exception Codes: 0x0000000000000000, 0x0000000000000000

Application Specific Information:
Assertion failed: (false), function FreeImage_AllocateHeaderT, file Source/FreeImage/BitmapAccess.cpp, line 337.

Thread 0 Crashed:: Dispatch queue: com.apple.main-thread
0 libsystem_kernel.dylib 0x00007fff88994286 __pthread_kill + 10
1 libsystem_c.dylib 0x00007fff8d781b53 abort + 129
2 libsystem_c.dylib 0x00007fff8d749c39 __assert_rtn + 321
3 libCommonImage.dylib 0x0000000112da4022 FreeImage_AllocateHeaderT + 1009
4 libCommonImage.dylib 0x0000000112da43ed FreeImage_AllocateHeader + 42
5 libCommonImage.dylib 0x0000000112dbbe87 Load(FreeImageIO*, void*, int, int, void*) + 797
6 libCommonImage.dylib 0x0000000112da976c FreeImage_LoadFromHandle + 175
7 libCommonImage.dylib 0x0000000112da5c91 FreeImage_LoadFromMemory + 64
8 libCommonImage.dylib 0x0000000112da0014 FreeImageUtils::CreateBmpFromMemory(unsigned int, unsigned char*, atlast::imageutils::EImageFileType*) + 82
9 libCommonImage.dylib 0x0000000112d99537 atlast::imageutils::ImageRep::CreateFromMemory(unsigned char const*, unsigned int) + 43
10 libCommonImage.dylib 0x0000000112d98fca atlast::imageutils::ImageRep::CreateFromImageFileRepToFit(atlast::imageutils::ImageFileRep const&, int, int) + 70
11 com.sketchup.SketchUp.2015 0x000000010e73f0f0 CDib::CreateImageRep() const + 66
12 com.sketchup.SketchUp.2015 0x000000010e73ef76 CDib::image() const + 34
13 com.sketchup.SketchUp.2015 0x000000010e7869fd CMaterial::UseTexture() const + 63
14 com.sketchup.SketchUp.2015 0x000000010e2afc6a GetNSColorFromMaterial(CMaterial*) + 199
15 com.sketchup.SketchUp.2015 0x000000010e2cd921 0x10e269000 + 411937
16 libCommonUtils.dylib 0x000000011353c6ec CNotificationCenter::SendNotification(char const*, void*) + 188
17 com.sketchup.SketchUp.2015 0x000000010e788b52 CMaterialManager::SendNotification(CMaterial*, EMaterialEditType) + 54
18 com.sketchup.SketchUp.2015 0x000000010e7895b4 CMaterialManager::Serialize(atlast::mfc::CArchive&) + 148
19 com.sketchup.SketchUp.2015 0x000000010e71fe78 CComponent::Serialize(atlast::mfc::CArchive&) + 76
20 com.sketchup.SketchUp.2015 0x000000010e7c911e CSketchUpModel::Serialize(atlast::mfc::CArchive&) + 1878
21 com.sketchup.SketchUp.2015 0x000000010e7c8120 CSketchUpModel::Load(atlast::utils::atlast_ustring const&) + 204
22 com.sketchup.SketchUp.2015 0x000000010e286c1f CMacSketchUpDoc::ReadFromFile(atlast::utils::atlast_ustring const&) + 23
23 com.sketchup.SketchUp.2015 0x000000010e26d28f 0x10e269000 + 17039
24 com.apple.AppKit 0x00007fff8a5bcd52 -[NSDocument(NSDeprecated) initWithContentsOfFile:ofType:] + 353
25 com.apple.AppKit 0x00007fff8a5d331d -[NSDocumentController(NSDeprecated) makeDocumentWithContentsOfFile:ofType:] + 102
26 com.apple.AppKit 0x00007fff8a5d3512 -[NSDocumentController(NSDeprecated) _openDocumentFileAt:display:] + 186
27 com.sketchup.SketchUp.2015 0x000000010e29f179 0x10e269000 + 221561
28 com.apple.AppKit 0x00007fff8a5d3672 -[NSDocumentController(NSDeprecated) openDocumentWithContentsOfURL:display:error:] + 137
29 com.apple.AppKit 0x00007fff8a5c3f71 __80-[NSDocumentController openDocumentWithContentsOfURL:display:completionHandler:]_block_invoke_4 + 1036
30 com.apple.AppKit 0x00007fff8a5c3113 -[NSDocumentController _openDocumentWithContentsOfURL:usingProcedure:] + 570
31 com.apple.AppKit 0x00007fff8a5c3b3f __80-[NSDocumentController openDocumentWithContentsOfURL:display:completionHandler:]_block_invoke_3 + 290
32 com.apple.CoreFoundation 0x00007fff93d7656c CFRUNLOOP_IS_CALLING_OUT_TO_A_BLOCK + 12
33 com.apple.CoreFoundation 0x00007fff93d68675 __CFRunLoopDoBlocks + 341
34 com.apple.CoreFoundation 0x00007fff93d67e2e __CFRunLoopRun + 910
35 com.apple.CoreFoundation 0x00007fff93d67858 CFRunLoopRunSpecific + 296
36 com.apple.HIToolbox 0x00007fff9257daef RunCurrentEventLoopInMode + 235
37 com.apple.HIToolbox 0x00007fff9257d76e ReceiveNextEventCommon + 179
38 com.apple.HIToolbox 0x00007fff9257d6ab _BlockUntilNextEventMatchingListInModeWithFilter + 71
39 com.apple.AppKit 0x00007fff8a167f81 _DPSNextEvent + 964
40 com.apple.AppKit 0x00007fff8a167730 -[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:] + 194
41 com.apple.AppKit 0x00007fff8a15b593 -[NSApplication run] + 594
42 com.apple.AppKit 0x00007fff8a146a14 NSApplicationMain + 1832
43 com.sketchup.SketchUp.2015 0x000000010e26b874 start + 52


#14

@Aerilius can you strip all the textures then copy paste the geometry into a new file?

that should confirm if it’s only materials at fault…

john


#15

Without textured materials:
https://drive.google.com/file/d/0B9AhVznpy1ygT3ZCV2NmS3J4VFk/view?usp=sharing


#16

This one opened and displayed briefly but then caused a BugSplat! I submitted it with a link to this topic.


#17

So it seems it crashes on a Mac but not on a PC. It is quite sluggish, though.

Anssi


#18

I just opened the no-textures version of this file in SketchUp with the debugger running and it’s crashing somewhere deep in the shadow rendering code. If I turn off shadows, the crash seems to go away. I’ll add this to our bug tracker, but at the moment I don’t see a workaround other than turning off shadows. It’s nearly impossible to tell exactly which geometry is triggering the crash.

I would recommend staying away from .psd images - I can’t point to a specific issue off the top of my head, but I believe we’ve had some cross-platform issues with .psd in the past.

Thanks,
Marc

(Incidentally, crash report 20374 in the SU 2015 Mac database.)


#19

This is great feedback people, thank you very much, I shall direct my colleague to this page and we can take it from there.

Much appreciated.


#20

•Turn on Hidden Geometry and then delete unnecessary geometry…
Is the massive ‘Thea Bowl’ component really necessary?
Notice there is also another exhibit in the model that is hidden. Necessary?


Purge the file


• After purging, click … Fix Problems