26MB SU Model taking ages to open


#1

Working again with Scott Baker (@NewThinking2) I’m trying to open one of his sub-models.

At the third or fourth attempt, I can now get as far as seeing his model appear bottom left in the SU workspace (previously, I got either no workspace window at all, or a blank white one). The rest of the workspace has a large black bar and other black areas in the middle. And the spinning ‘wait’ beach ball.

I have neither the Component Browser nor the Outliner window open, and the Layers window minimized

I’ve waited for minutes to see if this would clear itself, given time. Nothing happened for maybe five minutes, then the workspace display jumped, cleared the black bars, and centred the model in the window.

But if I click in the workspace, I get the spinning beach ball again…

More minutes later, the beach ball has finally cleared, and the model will allow me to select objects again.

But another couple of minutes later, and everything I try to do - cllck on a blank space in the window, select something, try to open the Model Info window from the menu, for example - triggers the beach ball again.

Sometimes, I CAN select something, change to select something else, etc without delay. BUt then the beachball comes back again later.

Before getting this far I have:

  • re-downloaded SU and reinstalled it
  • shut down the machine and done a cold reboot
  • checked with Scott that he can open the model without problem
  • got him to reopen his local copy of the model, make a small change, then Purge Unused and Fix Problems, then re-upload a copy to Dropbox, from where I downloaded it to try to open a local copy.
  • checked that I can open other models of a similar or larger size (they open almost instantly) from local storage

What else can I try to make the model (or Sketchup itself) usable again?

It is still intermittently becoming unresponsive for minutes at a time.

I’m now trying Select All/Copy, and then paste in place into a new model. I can do the select and copy, but the paste in place is hanging again.

… until it too finally clears, shows the pasted model, and appears ‘normal’ again.

But still with beach ball spinning a lot.

Tried Fix Problems - takes a while, but then says it didn’t find any problems.

Activity Monitor shows SU ‘not responding’ but taking 90%+ of CPU time.

Running High Sierra 10.3.3, SU 2018 Pro 18.0.16976

Finally succeeded in pasting copy into a new model, and saving it.

Will now close SU, and restart machine, then try to open pasted model.

I’ll upload both original problematic model, and copy/pasted one to OneDrive:
here’s a link to the original
https://1drv.ms/u/s!AuW7CgDj-R-tt3GxSNdu4Awj4PYA

And here to the copy/pasted version
https://1drv.ms/u/s!AuW7CgDj-R-tt3LnZd68AUHjjLUS


#2

After cold reboot, no apparent change - copy pasted model is just as slow to open, and behaving similarly when it DOES open - maybe a little quicker, but still with spinning beach ball even after first displaying on the screen bottom left, then jumping to put model in the centre.

Model is still not usable.

Any ideas, anyone, about how to fix?


#3

Let me have a look.


#4

Thanks.

One thing I have since discovered is that there are a LOT of dynamic component railings with drawn vertical rails… Whole model has over
one million edges.

I’m working slowly to put them onto their own layer then turn them off. The sheer number of edges slows everything down.


#6

I’m on a weak computer, I turned the face style to monochrome from texture and am able to orbit fairly quickly but component selection is a little delayed but usable. (lots of reversed faces) I think it must be all the edges of those railings holding the thing up. I don’t know if they could be simplified?


#7

You probably answered your own question. The problem with components is that they can reduce model file size a lot but still produce a lot of edges and faces for SketchUp to process.
Especially deeply nested components create problems (like a tree made of leafs that constitute a twig, twigs in a branch etc…). In some cases exploding the insides of a component actually make for a better performance, even if it results in a ballooning file size. I don’t know the ugly details about dynamic component handling but I guess that it might add still more twists.


#8

Well, I’m able to not only open this submodel, but the full 637MB model, and even move and edit it, albeit with delays. My AMD Radeon R9 M395X 4 GB card has a lag redrawing, but once a portion is cached, it is pretty spiffy.
The file takes 1-2 minutes to save or open, but I’ve turned off auto-backup so I can control when these breaks occur.
One thing I’ve discovered is that once SU steps over the performance precipice, it’s very hard to come back from. CPU cycles beget more cycles etc. in an endless loop, or close to it.
I have an 4 GHz Intel Core i7 and John has an i5. I have 32 GB 1867 MHz DDR3 and John has only 20GB and a bit slower.
I’m close to the edge, but John is over it, at least on the big model. I’m surprised the smaller model is such a problem at 1/20th the file size, however.


#9

How are you organizing this? I am guessing but isn’t the full model basically divided into components, of which this problematic one is one? These model parts are not directly interacting with the dynamic components inside. What I guess is happening is that your combination model takes the DC railings “as is” but when you either open the component file or open the component inside your main file for editing, SketchUp feels it must recalculate the positions and properties of every single railing part.


#10

What’s the end goal of the model?

In general it’s not very detailed when you look close so are you using this for a far view? If so then I would recommend using an image for the railings as there is no need to have them so detailed. If you need a close up then just make a few detailed apartments for that purpose that you can paste in when needed.

I can open the file on my laptop but it’s a pain and I would not be able to work on it in any meaningful way. It would probably run better on my PC but still I would advise cutting those railings.


#11

Absolutely. I’ve already replaced them in most other parts of the main model, and am intending to do so in this submodel. Here’s one to illustrate:

And a side by side comparison - imaged on the left, DCs on the right

The imaged railings are not only designed in such a way as to be ‘adjustable’ for length like ‘scaling’ a DC, but are much, much lighter in terms of edges and faces too. As you say, only in a few cases will we need close-ups where imaged railings won’t quite cut it, and those we can deal with as they arise.

But I’d originally thought the problem was a corrupted file. It’s become clear that the main problem is the sheer number of edges in the railings.

That sounds very plausible. For speed in modelling (at least most of the time) when creating this overall model, Scott used DC railings so he could adjust them quickly to fit varying sizes of terraces. But the result is EXTREMELY slow loading and editing later. And while we have both recognised the problem for a long time, it has taken us too long to get around to fixing it. Scott ‘got away with it’ for longer, because he has a significantly faster machine than I do.

Slowly, slowly, I’ve got the model usable again by turning off layers for all but one or just a few floors at a time, waiting each time for the beach ball to stop spinning, so I can clean up the reversed faces, and work on replacing the solid-drawn DC railings by imaged ones, a floor at a time.


#12

Thanks to all for looking at the model, and for making it clear that

  • I don’t have a corrupt file
  • I don’t have a corrupt SU installation

and that the problem is in the model itself and the sheer number of edges, quite probably compounded by the DCs recalculating.

That I can now see how to fix, a floor at a time.


#13

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.