Making sketchup free run faster


#1

Sketchup free is running very slow after putting various groups of furniture in the model. If I make them invisible (hide and uncheck display), will this make the model run faster? Any other ideas about how to make the model run faster?


#2

Same issues here. Let me know if you found a solution.


#3

the solution here.


#4

I wish it were that easy. I have an overclocked 8700K and 1080 Ti. Still runs slowly, even with a fairly simple model.

Anyone make progress on this front? I switched from Chrome to Firefox and found it crashes quite a bit less, but speed is still an issue.


#5

then it’s something wrong… besides your simpe model is not simple.

Ensure that the used browser does not run on an integrated graphics (as e.g. intel HD) but the dedicated GeForce.


#6

Well, I am gauging simple as this being just a single room of an entire house. The whole house model ran great on the desktop version of SketchUp.

It definitely is running on the 1080. Any thought on the settings?


#7

Maybe the team know a bit more, I’ve stress tested the online version with some pretty heavy models with moderate usability. What usually fails for me is not using the model but actually loading it into the app. Once its in generally behaves ok.

Ed: I’ve never got one of my 600mb models to load FYI, I’m running 980ti on the computer I test with.


#8

I hope to hear from them here. Besides general slow responsiveness, making components unique and painting them are especially slow, 25+ seconds each time.

I tried a few operations while watching CPU, GPU, RAM, SDD, and WiFi usage. All were minimally impacted, and I didn’t see any potential bottlenecks.


#10

Here’s a video:
https://www.youtube.com/watch?v=6NVizn537YQ

You can’t see my clicks, but whenever I wasn’t doing anything it’s because I was waiting for the action to complete.

Saving has a similar behavior.


#11

I’m not too familiar with Free, but are you able to switch the face style to monochrome and turn off what look to be back edges showing, while you are “working” on parts?
Would that make a difference?
Also, is the model located near the origin?

Just a few thoughts.


#12

Tried all that, no luck. Model is within a couple hundred feet of the origin.

While changing texture I did notice something though, while frozen from changing the texture of a part I could click several other parts and they would all have their texture changed at the same time, with no noticeable increase in the normal freeze time.


#13

It’s a bit late for me here but I think what might be interesting if you can download the model to your computer and upload it here on the forum. (If you wanted)
Someone could try it on desktop to see how it behaves and also try it on their end on Free.


#14

why then not simply use the Desktop version?

What does SU Desktop show under “Window > Model Information > Statistics” for the “Entire Model” and w/ option “Show nested Components enabled”?


#15

Trial expired haha.

I’ll upload the model when I have a chance, might be a couple days depending on how work goes.


#16

Its sidestepping the issue but, I kind of presumed from your post that it were your preference to use the SketchUp Free app over desktop. But, you say the trial of the desktop has expired.

What version of SketchUp have you been using for the last few years then?
You do seem to have a “serious” graphics card for a hobby user, are you using SketchUp commercially?


#17

The most I ever used SketchUp was waaay back close to when it first came out. Stopped using it for several years until I recently started trying it for modeling home improvement plans.

My computer has a few other uses - home automation/monitoring, gaming, mining, heating my office, and the occasional random project like the one in question here, so it’s a bit on the higher end. Definitely didn’t build it just for SketchUp!


#18

:smile:


#19

It’s nice in the winter, but I’m thinking of how I can vent the heat outside in the summer. It’s watercooled, so I could probably just put a couple lines through the wall and move the radiator outside. I’m also putting in a radon mitigation system as part of the project that is modeled here, so I’m wondering if I can somehow use that to vent the heat.

Speaking of the model, here it is. It is 60 MB or some reason, which I imagine is related to the problem if the problem is something in the file. Please have mercy on my lack good modeling practices.

edit Updated version in next post.


#20

You’d see better performance if you improve your modeling practices.

In this model, you’ve been using layers incorrectly even though you only have one layer besides Layer 0. Layer 0 should remain the active layer at all times–you have the Water System layer set to be active. All edges and faces should be created and remain on Layer 0 at all times.

There’s unneeded nesting of components.

There’s a whole lot of unneeded stuff in the model that should be purged.
Screenshot%20-%204_21_2018%20%2C%205_53_28%20PM

After purging the model of the unneeded components and materials the file saves out at about one tenth the size of what you uploaded.

Some of the components appeared to be needlessly obese. The ball valves have many unneeded edges and internal details that don’t add anything to your model except file size.

The gate valves are better but still a bit overweight. A number of the fittings are over-modeled and could be simplified without changing their outward appearance. All these things will impact file size and can impact the way your computer performs as you are trying to move around in the model and do any editing.

This is a quick GIF of your model running in SketchUp Free in Chrome after I purged the unused stuff and fixed the bad layer usage. I don’t see it behaving slowly.


#21

I found quite a few stray edges floating around too, but yes everything you said and the file is about 1/10th the size. I ran Cleanup 3 (you were much quicker as usual) This is before any additional component simplification of course.

Capture

New file size: