Problem 'extending a shape'

Hi there.

I’m struggling to extend this shape I’ve created, usually, if I select over the portion I want to extend, it highlights and I can use the move tool to extend it - as per the first example in the animation - a simple rectangle I made to explain what I mean. Yet if I try to do the same to the other shape, with the rounded corners, I’m unable to do this. Does anyone know why this might be?

Many thanks in advance for any support you can provide.

The 1st file attached is a video of what I mean, the 2nd file is the .skp file itself.

Thank you.


Untitled.skp (316.2 KB)

Turn on hidden geometry and it should work.

What Box said.


I used a keyboard shortcut to expose Hidden Geometry (View menu) and then the Move tool.

Amazing! Thank you Box, thank you DaveR.

In my quest to learn and understand SketchUp and not just be given the answers, please may I ask why I need to turn on hidden geometry when I’ve not needed to do this previously when extending objects, albeit more simple ones.

Many thanks.


The need to turn on Hidden Geometry depends on the geometry you are working with. If you were to extend the square-corners frame you would need to do that because all of the geometry you need to select is exposed. On your round-cornered that’s not the case without turning on Hidden Geometry. There’s a bunch of softened edges that don’t get selected if the hidden geometry isn’t exposed.

Notice how little gets selected without hidden geometry displayed.

Fantastic, thank you DaveR.

1 Like

You’re quite welcome. For this reason and others, I have the keyboard shortcut established. You might want to do the same thing.