Problem drawing circle

I must be losing it. My recollection is that drawing a circle entails first drawing a hemisphere. The attached graphic shows on the left how I started. With that drawing I selected the area of the circle then clicked the Follow Me tool then clicked the surface of the upright (vertical?) quarter circle. I got the image on the right.

What am I doing wrong? I’m confident that this the way I’ve done it in the past but memory fails too often these days.

Do you mean “Drawing a hemisphere entails first drawing a circle”? That would make sense. Drawing a circle uses a native SU tool.

I’m guessing that you may be suffering from Sketchup’s small edges issue.

What size are your circle and quarter circle?

Can you upload your model?

1 Like

Well, unless your circle and arc are VERY small, perhaps that’s not the issue. A 1" radius circle and arc works fine in SU 2017.

How are you using FollowMe? It works in two modes. The one I normally use is to first select the whole circle path, then select the FollowMe tool (the circle appears to then be deselected, but it isn’t). Then I click the profile face (the quarter circle in your example). That draws the hemisphere almost instantly.

If you leave the face of the full circle before running FollowMe, your hemisphere will have no bottom. If you want it to have a bottom, delete the circle face first.

By the way, you don’t need to draw the square.

To build on John’s reply check out the Video

Well, maybe it is small faces after all. If I scale my model down to one quarter size (circle diameter 1/2") then the top of the hemisphere doesn’t form.

And scaled down to one tenth size, NO surface forms.

So if your circle is significantly smaller than 1" radius, part of the surface will have edges that are too small to be created.

One option would be to use fewer segments in the circle, and possibly also the arc.

Or work on a larger scale and (if necessary) scale the result down after it has been drawn.

Or use the Dave Method - start drawing ‘full size’ and make a component, then copy it and scale up the copy by 100 or 1000 times. Complete your edits in the scaled up component (like running FollowMe for example). When done, you can delete the large copy but the small original will contain the scaled-back-to-size reduced copy of the large component. SU can scale edges down to a very small size, but won’t create them at that size.

If you are designing a model to be 3D printed, you can draw with units set to Metres, but treat them as mm. Export to STL as Metres, but import the STL file (which contains no units) as millimetres.

Or if you are working in inch units, treat Metres as inches, and import to the slicer in inches.

Good luck with your next hemisphere.

Thank you for the responses.

I think the problem might be one of scale. My attempts were with a radius of a an eighth of an inch. I’ll try a larger radius and use the scale tool to reduce it to the desired size.

I couldn’t break out of my mindset without your help.

Thanks, again!

Too small!

I changed the radius and was successful. Here’s the sphere I wanted.

Why is there a line round the ‘equator’? You can create a whole sphere by using a half circle profile instead ot a quarter circle.


And it’s often better to make the path circle bigger than the profile when making surfaces of rotation.