Printing in sketchup

I have Sketchup pro and I am trying to print full scale to use as templates. When i get to the printing set up the scale option is greyed out and cannot set the scale.

Sounds like you have the Camera set to Perspective. In order to print to scale you need to have the Camera set to Parallel Projection and set a standard view. Set a scene for that so you can easily return to it.

You should also look at using LayOut. You can make much nicer, cleaner templates from your SketchUp models with LayOut. Better options for paper usage and arrangement on the page(s).