Printing from LayOut is off-center: PLEASE HELP

When I print either directly to my printer, or first export to a PDF file, the appearance I’ve created in LayOut is off-center – everything is shifted to the left.

2021 Macbook running OS Monterey 12.2.1 (21D62), running Sketchup and LayOut version 21.1.331.

Attached you’ll find:

00 Page Setup dialog in LayOut
01 Screenshot of how my design appears in LayOut
02 Print dialog in LayOut
03 Screenshot of how my design appears when printed or exported to PDF

In every case except in how things look in LayOut itself, everything is shifted to the left.


Do you get the same results with LayOut 2022?

There have been some similar reports in the past. I saw one person indicating they found the problem was due to their printer or printer drivers.

It is possible on the Mac to create a custom paper size that’s not tied to any printer, and has no margins. You can then print to PDF and open it in Preview and see if you get better results printing from there. Not an ideal work flow, but maybe a helpful experiment?

Thanks DaveR:

I updated to SU/LayOut 2022, but the problem is exactly as before.

None of my other programs running on the same machine with the same printer have this problem.

Hi TRCool:

Thanks for the possibility. I tried this and the problem remained exactly as before.

I did this experiment before and after updated to the latest 2022 software.

I just spent the last 20 minutes wrestling with this issue with Layout 2022 after having similar problems woth Layout 2021. My preview and printouts shifted by 1/8".
Fortunately I remembered I documented this issue on the SU Forum.
I dont understand why this is needed but once I set the custom paper width no margins it allows me to print to 8.5 x 11 format.

See link below and scroll down to my postings:

1 Like

Thank you zaz1.

Unfortunately, this fix does not work for me.

Because exactly the same error occurs when exporting to PDF, and because no other program running on the same machine has this problem, I don’t think this is a printer or printer driver problem.

I think this is a SU/Mac-OS bug.

So unfortunately, still stuck.

I agree. Its definitely a SU/MAC bug that really should be fixed by the SketchUp team, but the workaround I provided in the link has worked for me. Although I am using a different printer than you. I typically print to PDF not paper. You wil know if things are going to work if the print preview has equal margins.

Did you setup the custom size with 0 margins on all four sides ?
In Layout Page Setup, make it your favorite by scrolling the list and right click, check mark should appear next to it ?
(I had difficulty making this my favorite using Layout 2022. So when I went from Page Setup to Print it still had the standard 8 1/2 x 11 selected and margins were offset. Once I got the default paper to be the custom 8.5 x 11 with no margins, landscape I could see it worked in the print preview.
Also, you may need to go into Apple System Preferences-> Printers and Scanners and check if the default paper size is now this custom no margin size.

I tried all of the things you suggested and still no luck.

Interestingly, if you check the box in the printer dialog called “Reverse Page Orientation” the images is correctly centered in the preview. See attached.

This may be a clue for the SU programmers.

Sorry this isnt working for you. I know its frustrating. Maybe @colin from the SU team will see this and have some suggestions.

Thanks Zaz.

Of course this had to happen the night before drawings are due to a small-town building inspector who hasn’t discovered this thing called the internet and requires paper for everything.

Had to resort to high-res screen shots (luckily the new larger MacBooks have lots of pixels) brought into Photoshop, and laid out and printed from there.


Geez, I guess I’m lucky I don’t have this problem. What’s the difference? I’m grasping at straws, so I’ll try another one - Is there any chance a mismatch between the printer driver’s page margins and LO’s page margins are part of this?

Here’s what I have done for Arch-D sheets (strictly for pdf since I don’t have a printer this size anymore):

Page Setup → Paper size:
Screen Shot 2022-03-22 at 9.29.35 AM

Custom Paper Size dialog:
Screen Shot 2022-03-22 at 9.28.36 AM

LO Document Setup → Paper:
Screen Shot 2022-03-22 at 9.30.23 AM

Is there a difference? Is is just because I’m on 2020 & High Sierra?

Looks like you are doing the same as what I do except with D size paper: no margin in Document setup and Page Setup uses a custom paper with no margins.

Is is just because I’m on 2020 & High Sierra?

Perhaps. I recall this issue started with me with Layout 2021 by which time I was running OSX 11 Big Sur.

It’s just over three years since I logged this bug. It happens if you have ‘Any Printer’ selected. Choosing a real physical printer works around the issue. Not sure why the HP DeskJet printer shows the problem.


Hi Colin,

If “Sketchup Team” means you work for Trimble, the bug I’m reporting is no different for “Any Printer” vs. my HP printer.

Please note that the bug appears in exported PDF files, as noted in my original post. Is there anything more generic than a “PDF printer”? I don’t think this has anything to do with my printer.

SOOOO, if you are with Trimble, is this something you would like me to intricately document so you can try to repeat it and squash that little gremlin?

It happens if you have ‘Any Printer’ selected. Choosing a real physical printer works around the issue.

Last year, using Layout 2021, I tried adding a physical printer and found no change to this issue- the 8.5 x 11" print preview was still cutoff. This year, after some frustration with the same issue on Layout 2022, I again tried adding the physical Epson printer and the issue is resolved. I also went back to Layout 2021 and it appears resolved there also. Now print preview is not cut off with the selection in page setup of a standard letter size paper. I updated all the printer software/drivers and installed OSX upgrades since last year so perhaps that also helped.


Yes, I’m a QA Engineer on the SketchUp team, though the printing bug I logged was during the time I was in Support.

I added a link in the bug report to this topic, and marked it to be reevaluated.

FWIW, my in office printers are Epsons, and when I make PDF’s on D size sheets it’s set to Any Printer, and I haven’t had this problem. Go figure.

Thank you Colin. If your team (or another) needs any help from me with additional details/tests, please don’t hesitate to reach out.

This is not isolated to mac I’m a windows 10 user with Sketchup 2021 and layout 2021 v 21.1.332. I’ve just come back to project after not using the software for a few months and it’s started having the exact same problem. It occurs regardless of whether I print .pdf or a physical printer. It also occurs with different documents with different page size and page orientations. I have used Layout for years and have had many issues with it…but never this.