Printing dimensions in Sketchup - size not predictable


#1

A weirdness, that carries over into Layout as well…

I have dimensioned a drawing in Sketchup, with the Font set to Arial 12pt. On screen, it looks fine, detailed, and legible, and about 12pt - so far so good.

When I print with Vector printing turned off, the dimensions do print, but VERY small (guessing, about 5 or 6pt on A4 paper) and quite faint.

When I change to Vector printing, the dimensions print huge, heavy, and far larger than 12pt (again guessing, about what I’d expect from 24pt type).

No happy medium.

Does Sketchup just not preserve point size when printing?

I can try again, with the font set to a fraction of an inch, but then the results vary according to zoom level in the view I’m printing.

Any suggestions, or is this just a know bug (or perhaps ‘feature’?

Mac OS X El Capitan, SU Pro 2016.


#2

Can you post a LayOut file that displays this? The views I have tested with show that text size in SketchUp and LayOut is quite consistent. SketchUp dimension arrows look ugly in LayOut as they seem to be sized to be about as big as the text.

Below, the dimension to the left was placed in SketchUp and the one to the right in LayOut. Both are 12 pt Arial. The viewport uses Vector rendering.

Anssi


#3

Replying from my phone. Will try it in Layout and post results when back at my main computer. Comment about Layout was based on previous experience, not from this file.

Screen shots in original post are from Sketchup Print dialogue preview and are just like what prints on paper.

I prefer to dimension in SU rather than Layout as the dimensions stay more easily associated with the model. So it’s a pity SU itself can’t print at the size I specified


#4

I notice your profile says you are on a 27" iMac Retina, which makes me wonder whether this is another example of SketchUp’s not-quite-ready-for-prime-time support of high dpi displays…


#5

It’s possible this is a result of the high DPI display - it’s a while since I was using SU on Windows with a Full HD display, and I don’t remember having these problems on it.

I’ve been experimenting a bit more with printing direct from SU.

I’ve tried changing the font to a Height measurement. Again, the results don’t seem as I expect.

If I change the font height to 1/2" (the width of most of the length-dimensioned pieces in the upper part of the model) it only occupies about half of the half inch in the model, and when I print it, is still too small.

I seem to get the best results from SU printing direct when setting font height to 1", taking 1/2" in the model, and coming out about right on the printout. But hard to predict since the results aren’t consistent, either relating the text size to the model scale, or keeping the point size consistent between screen and printout, never mind changing size by a factor of about 4x between Vector and non-Vector printing.

In Layout, using the SU setting for 12pt type and importing the model with SU dimensions, I get results a bit more as I would expect.

All but one of the dimensions here are from SU. This is what it looks like on screen (and in print), and you can see from the 24"dimension upper left, where I’ve also used a Layout dimension, why I prefer dimensioning in SU. I changed the view in SU slightly between adding the dimension in Layout, and updating the model reference, and the dimension (in Paper space) is no longer connected to the model endpoints.

And I’m sure it’s possible (I’m still very new to Layout), but I can’t see where to change the Dimension text size and style - it isn’t in the Dimension Style settings, nor in Preferences - perhaps in Document Setup? Nope, not there either, so where?

Maybe it IS a result of the high definition display, and SU not quite knowing how to scale things between model, view, and print?

Anyway, I’ve now got two usable workarounds - set the text oversize in model Height units, and print from SU, (result as below) - the text on screen still looks bigger than in print, but the print result is good.

Or I can import the model dimensions into Layout and print from there. But again, in the past, I’ve had examples in Layout where the dimension text went huge, and the arrows were also huge. All in all, not a smooth transition yet.


#6

A bit of further experimentation with SU Make on Windows 7 64 bit laptop.

Setting the font to 12pt Arial results in predictable and satisfactory Print Preview appearance when printing to PDF from this same model. Had a technical hitch printing to paper, which I haven’t time or energy to resolve tonight.

So it looks as though the sbaumgartner’s explanation is plausible - SU still hasn’t quite got very high DPI screens thoroughly worked out. A pity, because going back to my Windows 7 laptop to check this, on a 1366x768 res screen felt like the difference between early laser and dot matrix printers - looks VERY coarse, now I’ve been using Full HD and later Retina 5K screens! So I really hope that either a maintenance release, or SU 2017, will really tackle this problem.

And/or it’s a Mac problem specifically. As I haven’t got a higher-than-full HD screen on Windows, I can’t test that.


#7

I am also getting issues printing dimension text. Size 12 font prints out so small you cant read it (size 2pt?)
While printing out camera - parallel projection top view at 1:1 scale split across 2 A4 pages
Dell XPS 15" UHD laptop so HIDPI Windows 10


#8

The text printing thing can be an issue and it appears to be related to the hi dpi display.

As for printing to scale, IF the model will fit on a single A4 sheet at the set scale, you can get it printed on a single sheet. You have to resize the drawing window to match the aspect ratio of the paper. This is well-documented and there’s even a Skill Builder video on the topic.


#9

Thanks, I’ve watched that video before.

I’ve tried matching the app window size to the model so that there is little white space, but Sketchup will only let me get close margins on the left and right of the screen. I cannot minimise the white space top or bottom.
If I drag the window resize in bottom right hand corner, when I get to minimise the white space as I drag in smaller the image just gets smaller but the top and bottom white space never gets small enough.

In the print preview dialog, If I tab around and change the scale to 1:1, the Page size settings change to e.g. 281 by 231 which is larger than a4. Its as if the gui is reserving some white space for the camera view direction e.g. “Top” at the top of the screen,

My model is close to A4 in size - I can draw a box 278mm by 200mm to bound it
I am printing landscape and the model in landscape.
My printer margins would normally be 0.44cm (largest margin at bottom of page, lesser on other edges)
So it all should in theory fit within A4


#10

Do you set the drawing window to about the same shape as the paper and then use Zoom Extents?


#11

Yes as close as I could


#12

Hmmm…

If this is just for hobby use, you’ll probably just have to go with multiple sheets. I expect your model is just a little bit too large for the way borders are set up with the print driver.

If this is something you need to do a lot of, you should probably just use LayOut. It’s designed for printing to scale. You could add text and dimensions there, too and have better control over them.


#13

yes, just for hobby use, I was trying to print out a template for a router base.
Sketchup must reserve some of the whitespace for a border around the screen which is more pronounced at the top of the screen where the camera view is displayed, when I look at the two pages in preview, both halves take up less than the one sheet of paper and the two halves print quite close to the edge of the sheet (<5mm).

Thanks


#14

Check your PMs.


#15

SU has undocumented notions about how much of a border to leave, plus your printer may affect it. One has to experiment to find out just how full you can make the view before print spills onto multiple sheets, though as Dave has noted, the most crucial part is that the aspect ratio of the view window is close to that of the target paper.


#16

I have you SKP file and I’ll make a PDF of it. You model barely fits on an A4 sheet so it doesn’t surprise me that SketchUp can’t handle printing on one page. I’ll send you the PDF shortly.


#17

Click on a dimension to select it, then go to "Entity Info"
There is an option to "Change Font"
Under font sizes, you can define the font by “Points” or by "Height"
Default is font by points, but it you set by “height”, you can have the font display at an absolute size that behaves like other objects in the model.