Printer dialog - no units and no sizes and greyed out

Hello, I am using the trial version of sketchup, downloaded today. (29 days left)

when I try to print I can’t set the print size.

  • I have set the camera to parallell
  • I have switched of the let windows manage my default printer, in windows 10
  • I have set my printer setup to correct printer
  • It does not matter which printer I select the result is the same
  • Checking ‘use model extents’ makes no difference

what todo?

Generally when this has showed up in the past the problem has been traced to the print drivers. You might try going directly to the HP site to get the latest print drivers and install them.

When you installed SketchUp did you install it correctly? That is, did you right click on the download installer and choose Run as administrator from the Context menu?

It’s not relevant to this issue, but you need to correct your forum profile as often the specific version of SketchUp is important for analyzing a problem.

There is no such thing as SketchUp Make (desktop) 2020. The final (and only remaining) version of Make is 2017. Pro versions still start with a trial period, but they don’t revert to Make when it expires, they simply stop working.

2 Likes

I am administrator on computer. I have the same issue with the pdf printers. I have latest printer. Installed printer today

@DaveR thanks. Changed it now. Let’s hope I get it working before it stops working again then :joy:

That’s not the same as choosing Run as administrator from the Context menu for the installer. Suggest that you close SketchUp, find the downloaded installer, use Run as administrator and then choose Repair when the option presents.

I removed the appliation and installed it with “run as administrator” same problem

Try using a different printer driver, for instance a PDF printer, if you have one. Any change?

same issue,
It does not matter which printer I use or set as default. the result is the same,
should I try SketchUp Web?

My computer is brand new laptop with windows 10 , thinkpad T590.

Do you get a different result if you select a standard view of the model? What happens if you send the SketchUp to LayOut and print from there?

I do not have that options in Layout.
It does not matter which std view i use, same results

I seem to remember from this forum that the same problem was plaguing people who used the Microsoft PDF driver or some HP ones. Not sure, however.

What options are you referring to?

So far your screen shots haven’t shown an standard views of the model.

This post might be of use… Printing scenes - only ever prints current scene

That looks hopeful. I could easily get the symptoms by going to Print Setup, choosing the Microsoft print to PDF, then trying a print. All of the options were blank. Going back to Print Setup and choosing a real printer, then gave me all of the options in the Print dialog.

With your HP printer, do your page sizes appear in Page Setup? Have you selected a page size?
(or was it Print Setup, SU takes ages to to open on my old laptop, so I didn’t check)

Just so you know. I moved on to sketchup web and could do the printer setting I needed there.

Would you be willing to try the Print Setup solution that worked for me and others? Just to wrap up this topic, as well as being of some use to you.

If I had the onenote printer set when entering the print dialog I could see the dimensions but the scale (on the right side) was still grayed out so I could not print to a specific scale.

/T

I expect that was due to not having one of the standard views selected. The screenshots you’ve shown, anyway, have shown that you didn’t set a standard view.

No standard view set. Scale not available:

Standard view (Front in this case). Scale is available to set.