Preview in Google Earth - Grayed Out


#1

I’m trying to upload the building I have modeled into Google Earth. I have no problem downloading the location image into my model, but when I go to upload it, the preview button is grayed out. Do you now need the Pro version to upload models into Google Earth? Or do I have something not configured properly?

I tried searching all over the place to see if the Google Earth component is only a Pro version thing, but so far I have not found any definitive info.

Any help would be greatly appreciated!


Exporting a model from SketchUp to Google Earth
About the SketchUp category
#2

As you can see, the Google Earth button is greyed out and I cannot figure out any way to get this functioning.


#3

Confirm you have Google Earth installed on your computer.
http://www.google.com/earth/


#4

But I do and the icon is still greyed out a after geolocation. Must be something else.


#5

I don’t know what it could be. It is working OK for me in SU 2015 Win 8.1 32-bit.

Here I geo-located Steve on a bit of (frozen) Lake Geneva, Wisconsin and previewed him in GE.
(He needs a warmer jacket) Edit: (and a hat !)



#6

It doesn’t work for me though. (must be the cold, I hate it!)

I’ll try to find out why it doesn’t work. And post it here / or someone else may do the same.


#7

Yep. I am running the newest version of Google Earth and Sketchup Pro 2015. The Google Earth button remains grayed out no matter what I do.

I can’t believe I am the only one having this issue.
It is completely frustrating!!!


#8

Shot in the dark here;Have you tried older Su version and get the same problem. ( (Do your check at the same location.)
Rational based on info in this Why Google Doesn’t NEED Sketchup Anymore


http://help.sketchup.com/en/article/1267260


#9

Hi Sophiedog,

Are you able to go through the standard Google Earth export process? File > Export > 3D model > Google Earth file (.kmz)?


#10

Although not Sophiedog, I do have the same issue with the icon.
Yes, I’m able to go through File > Export > 3D model > Google Earth file (.kmz)
And then the model was visible when opening the kmz with Google Earth.
I temporarily closed Sketchup.
But restarting SketchUp 15 immadiately resulted in a bug splat.

After closing Google Earth I was able to start SketchUp again.
The icon is still greyed out.


#11

Thanks, @Wo3Dan.

@jody, @Tommy – has this been logged?


#12

I’ve only had one report of this in the emails yet but haven’t confirmed the reason. Note that this option will be greyed out on a system that doesn’t have Google Earth installed.

Presuming that Google Earth IS installed then my first thought is that Windows has lost the file association or SketchUp didn’t inherit it properly. I would start by uninstalling & reinstalling Google Earth so that all associations are freshly created.

Failing that, I would look into re-assigning the file association for KMZ and KML to be sure they’re pointing to Google Earth.

My experience in a fresh, new copy of Windows is that I didn’t have Google Earth installed and had the greyed out box. I downloaded and installed Google Earth and immediately had a nice blue icon. So, that does confirm that SketchUp CAN see it, the next question is why it isn’t visible immediately for some users. Historically we bumped into this type of problem because Photoshop would steal the reference to KMZ, this may be a similar problem.


#13

I was having the same problem but the solution was dead simple. I didn’t have anything drawn in my SketchUp workspace. I am guessing Sophie’s solution is not that simple. One thing (as Jody mentioned) is to check is to make sure that .kmz file extensions are associated with Google Earth. Newer versions of Photoshop are notorious for hijacking ownership of those extensions.


#14

Regarding the “Preview model in goggle Earth” why is this toggle/button grayed out and not working? what do I need to do to make this operable?

E


#15

i found out that if you installed “Google earth pro” you wont be able to preview your model in google earth, because the greyed label says google eart not google earth pro.

unless there is a way update the link in sketch up and relink google eart to google earth pro.


#16

I’m having the same problem. I recently went to Windows 10 and now have Microsoft Edge. I’m suspecting this has something to do with my problem but I can’t figure it out.