Preferred file location settings


#1

About a month ago, I uploaded Sketchup 2017 Pro. I have not used it much since uploading, but when I click on the icon which is on my desktop for 2017 sketchup, I get the following message. When I open up files, you can see all of the items in red. I tried changing the first item, no idea how I did that, and what I was doing, but I can not even back space or delete the first line highlighted in red. As far as the remainder items in red, I do not know what the “U” is. Any help in this issue would greatly be appreciated. Thank you.


#2

Could you post a larger screen shot of just the Preferences window so we have some hope of reading the text in the red boxes? Or copy and paste the paths so we can read the entire path text.


#3

You can select different paths by clicking the little folder icon at the end of each line.

Did you at some point have an external or network drive connected while using SketchUp? U: would the the system-assigned letter for such a non-standard drive. If it isn’t connected now, that would cause the problem you are seeing.


#4

I may have had an external backup drive, but I have not seen these issues before. I will post a larger screen shot as requested by DaveR, so you can better see the text. I just need to know what to enter, and how to do this, in each highlighted line in red. Thanks.


#5

Here is a larger image, I hope this helps. I need to know how to delete the ones in red, and than, how to enter a new path. Thanks.


#6

I was hoping you’d show us the entire paths. Did you try clicking on the “Change file location preference” button?


#7

Did you try clicking the folder icon?

That would test whether the path is actually accessible. Dave is right that the pencil-like button is what to click to change the preference setting.


#8

Hi guys, once again, thank you for trying to help me out. I will post two screen shots. One is models, which is an incorrect past highlighted in red, and the second shot is for styles, not high lighted in red

is correct (styles)


#9

Did you try changing the path for Models to the Documents folder?


#10

Yeah, as @DaveR mentioned, we told you where to click to change these settings. You haven’t said whether you tried that yet! But, if you have, is your question really what path these items should be set to?


#11

This is where I am getting lost. I can set my cursor in the red box, where it is blinking. I tried back spacing to erase. I also tried deleting, it would not let me. So, I next tried clicking on the box with the pencil. First, I went in the style box which is correct, copied that. Than, I went into the model box, deleted libraries > documents. Than I pasted the path from the style box, and changed the last word on the path from “style” to “models” Is this the correct way to do this. Once I did this, I hit enter, and I got another message that it could not find it. Is there an easier way to change these paths? Thanks again.


#12

the Select Folder button?

john


#13

@treeguyster Is there anything unique about your Windows user account? Are you using any network or shared volumes?

The fields that show the paths can’t be edited. You need to click on the pencil icon/button and navigate to the preferred folder/location. Once you’ve saved the location, that new path should show up in the field. Clicking the folder button/icon will take you to that same location, but it doesn’t change anything.


#14

You can’t edit the red text until you click the button Dave identified

SketchUp automatically creates folders for user-added items of some kinds, including classifications, components, materials, styles, and templates (and maybe others I forgot). It does not create folders for your models, that is entirely up to you. So, there is no “models” subfolder in the place where SketchUp created its “styles” subfolder. If that’s where you want to save your models, you need to create it. But it is probably better to create a subfolder for models in your documents folder since each version of SketchUp has its own set of folders for the things it tracks automatically.

You symptoms suggest that at some point you were working with the U: drive as your choice and this drive is no longer connected. You need to set the folder paths to something that exists and will always be available. External and network drives are not safe regarding their availability!


#15

Just out of curiosity, I decided to check my Sketchup 16, and Sketchup 15. The a attachment shows the file locations for both 15 and 16. I was recently laid off from my job, but when I was at work, if I saved anything, it went to at work what we called the “M” drive. My external back up drive is an e- drive, and I inserted a memory card from my camera, and that is the “i” drive. Not sure where the “u” drive came from. So, am I better off deleting Sketchup 17, and trying to reinstall it? Or, am I going to loose a bunch of information. I am not the most computer savy as you can tell. Or, what buttons do I push to get my file locations saved as I have in Sketchup 16 and Sketchup 15. Thanks again for all of your time.


#16

So you still haven’t told us if you clicked on the button I told you4 hours ago to click to change the path. Uninstalling and reinstalling SketchUp is a drastic step that is unlikely to change anything.


#17

Dave,

I believe I have solved my issues with all of your help. At least all of the file paths are not in red, and when I open Sketchup 2017, I do not get the same error message. Thank you all for your time.

Steve