Please fix the alt key and menu bar issue soon

I, and I am sure many others, use the alt key frequently with shortcuts. The odd behaviour of the menu bar being activated and not released as it should is significantly slowing down my use of this program. It is incredibly annoying to always be looking at the menu bar to see if it is engaged then having to strike the alt key again. Operation of the alt key modifier with shortcuts seems to inconsistently lock the menu bar, in my experience. Please please please fix as soon as possible.

How about today? Try installing the update from Download All | SketchUp. Make sure you right click on the downloaded installer and choose Run as administrator.

Thanks Dave!
Wondering where I exactly go to download the update. I am currently downloading sketchup 2023 again. Hope my settings are retained.

Jim Clendon

Hi Dave,

When I follow your link I get to the page below…
From here, I am not sure what do to to get the update…
I have follow the ‘Learn More’ link but that just takes me to marketing info…
I have tried to download Sketchup 2023 again and install as an administrator but the bug persists…
Help?

Is the update option from the screed below?

Oh boy Dave…
Can you tell from the screen shots below if I have successfully installed the 2023.0.1 version?
When I tested this version, using my alt modifier shortcut key the menu bar is still activated…

Sorry Jim. I was at Robotics all evening. Just got in the door. Looks like you’ve got the updated version and should be good to go.

Thanks Dave.
Is Robotics a club of like minded folks? Sounds neat.

Have you tested the alt key shortcut? For me the same issue is happening…

I am doing my windows update now and will try again.

Jim

It’s FIRST Robotics. I’m one of the mentors for the local team. See: https://www.firstinspires.org/

Yes. I have tested it. Did you restart Windows and SketchUp after installing the update?

Very cool team, I am sure a lot of technical creativity comes through!

Well, I am wrestling with this and loosing… I have updated windows, restarted my computer and closed out and re-entered sketchup.

I downloaded the .exe file below:

from the link highlighted below:

I then ran as an administrator as you suggested.

The alt short cut issue persists…

below is my test:

just drew a few edges:

then I use my shortcut key (alt + c) to connect all:

then I strike c (my shortcut to creat component) and the camera menu drops - AHHHH, very frustrating:

Thoughts?

I wanted to share with you that because of your assistance and insistence that I adapt layout, I was able to prepare the attached envelope detail that has been very well received by our staff and work, our subcontractors and our envelope consultant. Thanks again Dave!

230314-BOW360A-LEV2-BALC-PDF.pdf (3.27 MB)

I have Alt+C set to run CleanUp3 and C to draw a circle. It works fine to run CleanUp3 and then activate the Circle tool. I’m not sure why this isn’t working for you. Maybe a keystroke or mouse click is needed?
short

Maybe @colin will have some insight.

Good work on the envelope detail. I’m glad that worked for you.

hmm, an idea maybe. On mac, there are (were?) options to navigate menus using keyboard only, for people with various handicaps or a mouse-less environment.

If I recall, it was possible to activate it manually or through a shortcut.

Is there anything similar on PC ? could it be that some accessibility parameter somewhere is activated and would “force” this behaviour ?

The normal behavior on the PC is to press Alt and then the letter for the desired menu. Pressing Alt alone underscores the letter for each menu. Not always the leading letter of the menu name. This is in Paint.net.
alt

Yes, I know that part, but I’m talking about this :

Often, when doing class on a PC that belongs to the training centre, I’ll get a popup asking If I need the sticky keys, because when I show them how alt or ctrl changes the tool, I repetitively press my keys.

My question is, could it be that ? That sticky keys is activated on the pc itself, at least for the alt key ?
(I don’t have my PC right now, and I’m not sure where I would look, but I’m sure one of you has already tried it)

I don’t have sticky keys activated on my computer.

Maybe this is something the developers need to address.

I was a mentor on team 694 for many years. At first (no pun intended…) I helped the programmers, then later on the animators. Alas, they did tend to use 3DS Max, but I used SketchUp for making simulations of the challenge for that year.

Here’s one of the animations, which led to us winning the NYC regional that year.

1 Like

Well… For me, this alt key modifier for shortcuts/menu activation bug absolutely persists. I have tried everything recommended and the menu bar continues to be engaged in a way that was not the case with previous versions of Sketchup. I am not sure why this would be the case for me and not Dave when, I believe, I successfully updated to version 23.0.397. Speaking for myself, this operational bug continues to frustrate me as I use Sketchup.

As an FYI, another frustration with this alt key unusually activating the menu bar is my common use of the Alt+tab short cut to switch between applications on my computer…
i.e.
Here I am in sketchup [note, the menu bar is not engaged with underline letter of the File/Edit/etc drop down options]

Below is after I use the Alt+tab short cut to switch away and back to sketchup:

The menu bar option are underlined and I have to strike alt again to disengage them…

This odd behavior does not occur in any other program I use…

I believe this bug is NOT resolved, at least for me.

Is anyone else experiencing this? It significantly effects my workflow fluidity…

Thank you,

Jim Clendon

hi. I’ve managed to reproduce the effects you’re describing. through the things I was talking about in my previous message.

on my PC, by going into the windows preferences, then accessibility, keyboard, if I activate the sticky keys, I have the same behaviour as you.
(or you can search sticky keys in the pref panel)

Can you confirm your sticky keys are not activated ? and if you click on the option, can you confirm that all sub options are off aswell ? (stuff like the shortcut to activate it and such)
That could solve everything.