Please Confirm Sketchup Pro 2021 (Oct 2021) Does Use GPU

There appear to be a few older threads for the GPU not being used error.

“Warning: SketchUp has detected you are using a “Intel(R) HD Graphics 520” graphics card when your system is capable of using an AMD or NVIDIA graphics card. SketchUp will likely perform better if you change your system to use the AMD or NVIDIA card.”

As of Oct 2021 it appears Windows does not let NVIDIA select what uses the GPU.

you need to use Windows graphics settings to do so.

I’ve done this.
I also made sure my drivers were up to date.

System Info:
LaptopL ASUS Model K501UW (mid range but ~5 yrs old)
Processor: Intel(R) Core™ i7-6500U CPU @ 2.50GHz, 2592 Mhz, 2
GPU: GeForce GTX 960M

When i start SU or Layout, i see only the CPU used (~30%) and get more when I’m updating models in Layout. The GPU never really moves.

I’m starting to think I’m crazy and online now with Window Tech Support.

Can anyone confirm when they are using SU or Layout that the GPU is being used?

Thank you!
-jesse

and now for a little comedy!

Try orbiting and zooming with shadows turned on

Try right clicking on the SU icon and see if there is an option for using high performance graphics.

1 Like

LayOut uses SketchUp settings.

In SketchUp, go to:
Window (menu) > Preferences (dialog) > OpenGL (panel) > Graphics Card Details (button)

It will show which driver is being used, … the Intel or the Nvidia, viz:

image

Awesome thank you, orbiting does it in both SU and LO.

My initial setup was working I assumed launching SU or LO was enough to trigger the GPU. It is not. Thanks @MikeWayzovski for an adequate test.

Thanks Dan, but here is an odd one. I confirmed my GPU runs. Turns out panning is enough compared to just starting the program. Odd thing is I just checked my graphics setting and it still points to the CPU.
image

I am not sure when windows 10 took control GPU allocation away from NVIDIA’s control panel or setting up but maybe SU code hasn’t caught up to their change. Thanks again, back to work I go!

The 1st image you showed in the 1st post is showing Nvidia Control panel’s Global Settings tab.
Is SketchUp set to something on the Program Settings tab ?

Usually the Global Settings should be enough. Of course, in Application settings you can override the global setting.
Are you using an external monitor? Are you connecting one through a “dock”? Some of these refuse to let Nvidia graphics through.

1 Like

yes and yes, 2 external monitors and a USB3 docking station