Pinwheel of death and extremely slow response of Version 20.1.228

I just downloaded Sketchup Pro Version 20.1.228 for Mac. Initially it was working great but for some reason it has been operating very slowly lately. Every time I try to perform any action (clicking on menu, selecting object to perform operation, performing operation, etc.), the pinwheel of death will appear and it will react extremely slow and choppy. For example, if I were to select “push/pull”, the pinwheel will show up for a few seconds before the “select” arrow turns into “push/pull” cursor; after selecting the surface to “push/pull”, the pinwheel appears again for a few seconds; when I try to move the surface, it doesn’t react and the pinwheel appears before the surface jumps over to a different location I’ve moved the cursor without gliding smoothly. This happens with every action/operation.

Why has this suddenly started happening when it worked fine initially?

Why version 2020.1 ? If you just downloaded, it should be 2020.2 With that new version, you need to drag the SketchUp Icon in the App folder, like it was before (2020.0 and 2020.1 had a different installer)
Maybe something is messed up.

I downloaded what was supposed to be a 2020.2 and it was a file type of “disk image” or “.dmg”. When I click on it, it says it’s going through a “verifying file…” procedure and then instructs me to go back to the file folder. I click on the SketchUp program icon and it still opens 2020.2

I apologize, it opens 2020.1 after going through what I thought was the installation of 2020.2 so I’m not sure what I’m doing wrong.

You may be misunderstanding the installer. When the .dmg opens (the verification step is macOS checking it’s signature), in the resulting window you drag the SketchUp icon onto the Applications folder icon to do the install. SketchUp 2020.1 must not be running when you do this else the install will fail.

They could have made it a lot easier if they just wrote the words “Drag Sketchup icon above into applications folder to the right to begin install” or just have it happen automatically!

Thanks for your help! it worked!

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.