Photomatch - photo coming in always at 90 degrees! Please help!

Hi

I’m having an issue where my photo is coming into photomatch rotated 90 degrees no matter what I do.

First I import it like usual (choosing the photomatch option). The image comes in rotated 90 degrees to the right.

So I go into Photoshop and create a version where I’ve rotated it 90 degrees to the left.

But when I bring that photo in, it comes in just like it looks in photoshop - rotated 90 degrees to the left! I cannot get an image imported to the correct orientation. What am I doing wrong??

Thanks

Are you using Match Photo for the first time?
If not, has it worked correctly so far? What exactly has changed on your computer in the meantime?
If you open the photo modified in Photoshop in the viewer of the operating system, is it oriented correctly?

le t me guess, vertical photo ?

few years ago I read that all photos made by a phone are horizontal. BUT the metadata attached tells the machine if it has to be displayed vertically and if so, what side up. I suppose it uses the phone’s gyroscope.

I remember reading this because at the time, another software I used refused to display some photos vertically. Looks like it simply bypassed the metadata in some cases.
The solution I found was indeed in photoshop, open the photo in photoshop, export it as png. modifying it and saving it upon itself would keep the faulty metadata. making a png or a new jpg out of it would create a whole new metadata info.

I’ve had the problem a few month ago in photomatch, first time in years, did the png trick, it worked.

edit : can’t find the original article, but I wonder if it had to do with the JPG / jpg / jpeg difference.

this is the original JPG, metadata ignored.

export from photoshop as a png, a jpeg, a jpg but in a DIFFERENT file (don’t overwrite the initial one) and you should get this

1 Like

I have used photomatch successfully many times. I don’t think anything has changed that I can think of. I’m doing it on my work computer (a PC not a Mac). I thought I’d done one before on it but maybe not.

I will try that. Yes, it is a vertical photo, taken on the iPhone.

Have you reoriented the axes ?

Right click on any axis and see if the Reset option is available.

That worked! Thanks so much for your help!

same on my end.

I wonder if the photos I’ve used in the past that didn’t cause any issue were iphone-made too, or android. that would indicate something in the iphone metadata is not read or exported right.

the photo is the issue, in my case, it’s not working right in plain empty files, on pcs and macs, 22 23 and 24, on machines where SU was installed 2 days prior and older ones…
but just opening and exporting independently fixes all. go figure :slight_smile:


For future reference, no need for photoshop.

Just open the image in your image software, and export it as a jpg (or png) somewhere else. Just tried using preview on mac, it works.
creating the new file must be fixing a permission or a parameter somewhere.