Phantom screen labels

I use the web version of SketchUp - the product some of you call SketchUp Shop but my screen says “SketchUp Web”. I understand that most of you use SketchUp Pro - the desktop version.

I frequently get a tiny label stuck on my browser screen - an artifact of some tool I’ve used - that won’t seem to go away. I have to close the browser window and re-open it in order to clear the label.

I suspect this is a matter of some interaction between the SketchUp JavaScript and my browser (Chrome).


This is a known issue which has be noted and acknowledged several times. No concrete news yet about when it might be addressed.

As EF wrote, the sticky tool tips thing has been reported. Hopefully it’ll get sorted out soon however considering that many of the SketchUp folks are off this week for the Christmas holiday, it might not happen right away.

FWIW, I moved your thread to the SketchUp Shop category.

Was this issue resolved? I am having the same issue.


What browser are you using? I was seeing it a while back on Chrome but then there was an update to Chrome and it isn’t doing it anymore.


I tried closing and reopening the file but ENDPOINT still stays on the screen after I dimension. Click on the tape and ENDPOINT goes away.

See if you can update Chrome. It seems like there’s something with the browser that makes this problem appear or not appear.

Switching to the LINE tool and then hovering elsewhere removes the rogue label without having to save and exit. An annoying little bug.

What browser are you using? I was seeing this in Chrome until a week or so ago. I updated Chrome and the problem went away. It seems to come and go with different versions of Chrome. It is an annoying bug and I wish Google could get it sorted out in Chrome once and for all.

Not a fix, but a stop gap. I have exactly the same problem. I am able to make the messages go away by pulling the face of some geometry so that the object blocks the message. Then I just hit CTRL z to undo and…Voila. the evil message is banished. At least you don’t have to exit out.

Google Chrome is up to date
Version 90.0.4430.93 (Official Build) (64-bit)
I can’t imagine someone getting this far on the thread and doesn’t use Chrome (which updates automatically). I use the latest version and still get this annoying bug… and I too only notice it when using the Dimensions tool.

Does it happen with the Edge browser?

Yes, it also happens with the latest Edge browser. Took me 20 seconds to recreate the issue (first try).

I commend you folks for trying to figure out what causes this problem and how to fix it.
When I reported the problem almost a year ago, I was told that Engineering was aware of it and the issue would be fixed soon. Six months later, I finally tired of the problem and dumped the web version of SketchUp in favor of the desktop version. I’m a big fan of browser-based software - when it works. I have little patience for companies that don’t promptly address known bugs.

1 Like