Performance suddenly dropped after adding shortcuts

performance
shortcuts
#1

This might sound ridiculous and I can’t find anyone reporting the same issue, but SU has suddenly started working really slowly and struggling with everything I try to do - even selecting/deselecting parts of my model, rotating etc.

Earlier today I was working on a model and all was working perfectly, when I realised I still hadn’t got around to configuring any keyboard shortcuts. I went into my preferences and added around 5 keyboard shortcuts for things I use a lot, such as, zoom extents, hide/unhide etc. When I resumed working on the same model (I didn’t close and reopen SU) everything was suddenly really laggy. It seems ludicrous that the two things could be related, but it was quite strange that it happened immediately after. Any ideas?!

Thanks, Will

#2

I expect the addition of shortcuts is a red herring. There have been numerous reports of SketchUp getting sluggish. Plenty of threads to be found in the forum. It could be related to a Windows update that was bad or a graphics driver that needs updating.

When you installed SketchUp, did you right click on the installer (exe) file and use Run as administrator? If not, you should find the installer file and re-run the installation using Run as administrator. Then choose the Repair option. See if that fixes it.

1 Like
#3

When you installed SketchUp did you select its installer exe file [probably in your Downloads folder], right-click > context-menu > "Run as administrator"
Installing in any other way - e.g. being an admin and double-clicking the icon - will cause problems down the line.
If not it can cause weird issues.
There’s probably no need for an uninstall/reinstall… close SketchUp and rerun the installer as explained above.
When prompted choose “Repair”, and the installation should now be sorted ?

1 Like
#4

Seems to have done the trick - the shortcuts thing was definitely just a red herring, but thought I’d just double check it wasn’t a weird bug!

Thanks very much @DaveR and @TIG!

1 Like
closed #5

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.