Paste in Place DEFAULT

I think that Paste in Place should be the default function for the keyboard shortcut CTRL + V. When you use CTRL + V to paste a copy of an object, it selects an insertion point for you, which makes inferences not immediately helpful. you then would paste imprecisely, only to then have to select the move tool in order to select your inference points.
in contrast, if when you select an object, CTRL + C, then CTRL + V it pasted it directly in place, you could then hit the M key in order to move the object to another location. I almost never want a copied object to be in a different location, as i’m usually copying and pasting from one group into another, or from one project into another. when I want to make copies of an object in an array or to a different location, I use the move tool + CTRL key.

I would like to see it be the default key command. but if that is not widespread in acceptance, i’d at least like the ability to change it myself. right now, in sketchup 2021, when i change that shortcut, it says that im overriding the default paste shortcut. everytime i open sketchup, even though i have confirmed the change, saved the file, I have to redo that user created shortcut. I suspect it is because i’m overwriting a default, vs. setting a brand new shortcut command.

Why don’t you assign Paste in place a keyboard shortcut. I have assigned Paste in Place to Alt+V and it works great. You might be able to reassign Ctrl+V to paste in place if you want.


agreed, that would be sufficient. That’s what started this for me. I am used to ctrl + v, so i was trying to assign that to edit/paste in place. when i set it, it lets me know that it is the command already used by edit/paste. and it asks me if i would like to reassign ctrl + V to edit/paste in place, and I say yes. That allows me to use the key command as i’d like. but as soon as i save and close the file, that keyboard shortcut goes back to the default, and i change it every time i open sketchup. that is not sustainable. it is such a common annoyance to me, i’m reaching out to beg that it be fixed or changed to the default.
does anyone else have issues with user shortcuts not saving?

1 Like

The shortcuts should be saved upon closing SketchUp.
You need to have one instance running, set the shortcuts and then close SketchUp.
Each following opening of SketchUp should remember those.

If not, there is a problem with your set up and youj could try to repair the installation

I’ve followed those exact steps. I just left one company and started at a new company yesterday. I was having this problem at my last company. I wondered if it might have something to do with my set up. But it is the case here as well. It’s unlikely that both company’s IT have installed something incorrectly. In past versions of sketchup i was able to save shortcuts. I’ve only experienced this issue in 2021. are you running 2021? would you mind trying to make that exact shortcut change and tell me if it works for you? I am suspicious that it particularly doesn’t like me overwriting the default shortcut for paste.

I’ve encountered this with ‘system’ and certain other shortcuts reverting in SketchUp.

I use AutoHotKey (Windows) to assign v to paste in place and c to copy.

( If I’m in a text field AHK detects this and uses ctrl c and ctrl v )

You need to set some modifier + key shortcut in SketchUp for paste in place then use AHK to create the required hotkey to perform the modifier + key when in SketchUp.

1 Like

On Windows you might be able to use Powertoys Keyboard Mapper to assign ctrl v (when in SketchUp) to a modifier + key for paste in place.

Open an explorer window and navigate to %LocalAppData%\SketchUp\SketchUp 2021\SketchUp\PrivatePreferences.json

When you close SketchUp, it should be updated (check the time)

If not, something is not right.

1 Like

Over the years done that many times Jack.

Keeps doing it.

Even directly edited the file.

Just couldn’t be arsed anymore so ended up using AHK and then Powertoys when that came along.

Ctrl+V is a default keyboard shortcut for Paste in the operating system. Like other OS-coded shortcuts (Ctrl+A, Ctrl+P, Ctrl+X, etc.) you can set them for a given SketchUp session but the operating system will take them back when you close. Using something else for the shortcut or a different application as Paul does would be the way around it.

Like @mballes I find Alt+V works fine for Paste in Place. It’s been my keyboard shortcut for that for more than 10 years.


Sketchup saves the shortcuts in a file called preferenced.dat, open in a text editor and modify the file to your liking. It should then load for each sketchup session.

Actually export the preference.dat and then if you need to you can reload it if necessary

I don’t think you could be saved, anymore :grinning:
Windows is not my main platform, so I did not test it.

Wondering why it is paste in place in LayOut, though.
Might be a bug

On Mac the default for paste is cmd-v. So I set ctrl-v to be paste in place. Honestly I must use paste in place 20 times for each time I use paste!


I rarely use Paste in SketchUp myself.

i hate to bring rhino into this, but their default paste is paste in place. it makes too much sense to me. I agree with slbaumgartner, i almost exclusively use paste in place. that’s why i think CTRL + V should paste in place.

1 Like

I agree. I’d welcome that. But sure as shootin’ as soon as they institute it there will be others complaining about it.

here’s an interesting development. I made the changes again to the shortcut. saved the file. exported those shortcut preferences. closed sketchup. opened the file. imported those preferences. that user created shortcut had gone back to the default.
i’m losing my mind!

As I wrote before, if you change Ctrl+V to Paste in place, it will last until you close that session of SketchUp. When you close it, though, Windows takes it back because it’s hard coded in the operating system.

do a search for preference.dat and make sure there is not more than one file out there. I had an issue where there was more than one and Sketchup keep opening the wrong file.