Painting surface


I am rather new to Sketchup, been using it for 3-4 months maybe. I created couple of models but only this time encountered such a problem.
When I apply paint to the surface I get two different layers (?) of this paint. Although the layer dropdown list has only one position - layer0.

What I did was selecting the whole project and painting it white and then applying colors only to selected surfaces.

Now one layer, first (see screenshot attached), is white and is not visible in Sketchup viewport but is being rendered by all renderers I tried, second, brown, is visible in Sketchup but omittted by renderers, so I get incorrect renders. And now when I apply colors only the brown layer is being edited.


  1. When I already have these two layers - what can I do to remove one of them to render and edit only one?
  2. What should I do (or not do) to avoid creating two different paint layers in the future? Because I am totally sure I only applied paint couple of times to the same surface.

That’s not showing two different layers of paint. It’s showing the material applied to the front face and to the back face. What your screen shot shows is that you have a white color applied to the front face and a brown color applied to the back face.

The fact that you are seeing those faces rendered in white and not brown implies that you have the faces reversed in your model. Fix the face orientation and things should work out the way you want.

You should be correcting face orientation as you go to make sure you have front faces on the outside. Make it a habit to keep back faces on the inside. If you do this as you go along, you’ll find the model is easier to work with and your renders turn out right the first time.

1 Like

Thanks for your reply.
So the correct way to establish face orientation would be applying color and test rendering?
Plus I don’t know what I did wrong in the first place.

No! The correct way to establish face orientation is to look at what is displayed before you apply materials. Look at the face color settings in the style you’re using. The cylinder in the thumbnail shows the back face color. The default is a bluish gray color.

I find that blue is sometimes difficult to discern as different from shaded front face colors so I use a green that I’d never use in a model.

There are a number of reasons why faces might be reversed. It happens from time to time. It’s not necessarily that you did anything wrong to get them. You just need to correct the orientation when it happens.

Don’t be in a hurry to apply materials to the faces in your model. Make sure the faces are oriented correctly before you paint them.


Just to add to the above, you can right click on any face and click “Reverse Faces”. This will automatically reverse the orientation of the faces including the selected material.

1 Like