Paint bucket - BUGSPLAT - when using paint bucket textures

I recently tried painting an object in 2021 Sketchup using paint bucket menu and the textures option, or the brick symbol. Upon clicking the brick, a bug splat occurred with the notice, and upon sending the response back to Sketchup mac settings sent one of those ‘Sketchup quite unexpectedly’ notices which contained a large set of codes. The same happened to my friend when clicking the same button. Does anyone know how to fix this as it is needed as soon as possible. Thank you.

This indicates that SketchUp is not starting from the right location.

Thank you, I will try this.

I checked, and I think you are running SketchUp from the right location, but you are using the older version. Try this one instead:

Mac 2021.0.1

Thank you - it solved the problem - but will there still be bug splats upon using the paint bucket?

I don’t think so. The new version took care of something that was specific to the issue that caused the crash when using the paint bucket.