Page Scroll away when selecting tool from Large Toolbar?

osx
sierra

#1

About 70% of the time when I click on a tool in large toolbar (as opposed to using keyboard shortcut) my page scrolls away to some other place on the drawing page. I then have to pan back and select the tool again then it scrolls away again. By zooming or other trick I can finally get back to where I need to work. If the tool has a shortcut key I can use that and the scroll away does not happen, but I do not have shortcuts to all the tools.
Any idea why this is happening.??


#2

What operating system are you using? What graphics card?


#3

Does this provide you with enough info???

Does


#4

I’ve not experienced what you describe on my mid-2012 MBPr. It sounds like there is a problem with spurious pointer events (trackpad or mouse). Here are some ideas to try:

  • Do you have “tap to click” checked in the trackpad System Preferences? If so and you have to lift to move the cursor over to the toolbar, that might generate a click partway there.
  • Are you using an external mouse? Perhaps you could try a different one and see if the problem goes away. I sometimes get phantom clicks from my aging USB wireless mouse
  • If using an external mouse, are you careful to keep your other hand away from the trackpad while mousing? You could try enabling “Ignore built-in trackpad when mouse or wireless trackpad is present” in the Accessibiity->Mouse & Trackpad System Preferences.

#5

Have tried all of those and still get this strange jump. It particularly doesn’t happens when I select tool shortcut. Very strange.


#6

I’ve experienced this exact problem for quite a while now. I’ve changed versions of SketchUp and still the same result.

MacOS Sierra, Iris Card, Using touchpad…

It occurs when you have completed a drawing function, and attempt to reselect another tool, typically the arrow select or line drawing tool.

The screen begins to scroll (drawing goes up, screen goes down).

I have not had this issue running SketchUp on a Windows machine, only on my MacBook Pro (early 2012).

No settings changes, tool bar changes or preferences changes alleviate the problem.

A hint from the SketchUp team or at least investigation would be helpful, it’s only sheer luck I found this thread searching the web…the search text gets’s buried in a million links on how to use the ‘move tool’ or other such advice!

Thanks…

PS-the touchpad/mouse events described to check for would be obvious in other software or uses…this is a SketchUp Only issue in my case…currently making SketchUp unusable…


#7

The workarounds that I have found are 1) to select the next tool using a keyboard shortcut (usually though not always alleviate the random scrolling) 2) Stay zoomed out far enough or zoom extents to get back to the place I was working and 3) once i ge tool i want then just brute force go back to where I was hopefully not having to change the tool to get there

Yes its a quite an annoying problem. I had it before Sierra too on Yosemite.
And the suggested preference changes and settings changes I had done months ago when it first happened.
Not my first Big Rodeo using a complex program.


#8

So if drawing goes up, screen goes down: a question in addition to @slbaumgartner, and did you try his?

Does that mean it’s more like pan? Which, on a trackpad would be cmd-ctrl-shift click-hold and scroll upward… does it behave like that, and does the tool cursor change or remain the same? I’m wondering if there’s an interfering keyboard shortcut being fired somehow?

Googling around only returned this “replace your trackpad” response.


#9

Sticking my nose in here—I appreciate all the new activity on this…really. Will try to give as much info as possible on my experience…

For me, it’s related only to touchpad use on the MacBook Pro while running SketchUp.

Things I’ve tried:

  • Barebones apps running, no screen savers, open apps or 3rd party apps. (Sketchup & MSOffice are the only apps installed that’s are not App Store apps or apple preinstalled).

  • Acceleration preferences…pick one, I’ve tried various variation, no change. SketchUp is a vanilla install.

  • I have no keyboard shortcuts or scripts in the back ground, running the MacOS default shortcuts only…

  • Added a mouse, and the results are much less drastic, but the screen still scrolls, perhaps 3-4 “lines” as opposed to 15-50 “lines”.

Absolutely. However, I imagine a pan would/could typically be multi-directional, while this is vertical only as you describe in [quote=“Barry, post:8, topic:41121”]
on a trackpad would be cmd-ctrl-shift click-hold
[/quote]

and yes, the tool remains in a “tool button state” of depressed until the scroll stops…almost as if there is a process script running in order to complete the tool function, and then it cycles to the next selected tool. Scolling relationship to tool selection pause isn’t correlated.

OK…so I just attempted to replicate the issue with a screen grab. Mouse plugged in, track pad behaves normally. Unplug mouse, trackpad behaves normally. (SV 17.2.2554)

Reboot without mouse, load SketchUp, trackpad starts to scroll.
I have some assumptions, but I’m not the expert :slight_smile:

Although I’ve stumbled upon a way to fix it, that might not be an option for MacBook Pro users without a mouse.

Just curious - Is there code in SketchUp that differentiates between track/touchpad interface commands from the OS and a three button mouse?


#10

Most of the time it acts like a pan in that the size of the view doesn’t change it just gives off to some random location.
Mine is not particularly up/down or left/right but can be off a t a n angle too.
Usually not to a place used in the drawing. Cursor stays the same.
It does seem like it is a shortcut somewhere being fired but somehow ages locked on. I’ve then taken my hands off keyboard and it still goes.


#11

Ive had the problem with with and without a mouse.


#12

LOL…I figured your reaction to [quote=“slbaumgartner, post:4, topic:41121”]
are you careful to keep your other hand away from the trackpad while mousing?
[/quote]

was same as mine…would seem obvious it’s not a system wide issue, but a SketchUp isolated problem…but I guess no harm in his response to check for that first…just in case…I guess. :sunglasses:

For what it’s worth Barry - I’ve backtracked to SU2013 and SU2015, and the problem to my knowledge has been there since then. My last recollection was like SketchUp 7 or 8 not having the issue…

Does it react the same for both? For me with the mouse it’s a slower scroll, but without it, it’s like you’ve described…really fast, and you have to catch it.


#13

I can see how that might have sounded like an insult or somewhat stupid. But I asked because I’ve noticed on my MacBook Pro that I sometimes get incorrect inputs when my left hand is resting on the flat surface next to but not actually on top of the touchpad while I use the pad with my right hand. I think the touch sensor is capacitive, so a nearby hand could in principle look like another finger.


#14

Wasn’t diss you It was the original suggestions to change preferences.
I have that problem with trackpad because of a lazy thumb so I was aware or =f checking that first.


#15

This topic was automatically closed after 91 days. New replies are no longer allowed.