Outliner refresh lag with large files. Is there a solution?

lag
sketchup

#1

Hello folks. I need some advice.

I am working on a large project that will eventually reach around 2000 components. I will be using Sketchup strictly for 3D modeling of objects. I will not be using shadows, textures, or rendering.

At present i am running some tests to determine the capacity of my system and whether it can handle the 2000 components.

To run this test i created a cube, made it into a component, and then copied it 2000 times into into a 100 x 20 matrix.

Now i start to orbit, pan, and zoom with slight lag that is tolerable. I then edit a component and i am able to triple click to select all the faces and edges with a little more lag but still workable.

However, then i open the outliner window and try to triple click on a component that is in edit component mode so that i can select all the faces and edges and nothing gets selected. If i hide all the components in the scene or use the hide similar components feature i am still unable to triple click to select all the faces and edges. If i nest the components there is even more lag. If i reduce the anti aliasing to 2X nothing changes. If i use groups instead of components the problem still remains. So this leads me to naturally conclude that there is an issue with outliner when it gets refreshed, an issue other users seem to have mentioned already in other posts that i have read.

Now i can workaround this problem by closing the outliner window everytime i want to work on a component, but i find it somewhat bothersome, especially if there is something that can be done about it.

I have checked my system RAM and video RAM and they are not being maxed out or anywhere close to being maxed out. So clearly the bottleneck is not there.

I have tried putting my CPU into turbo but did not notice any changes.

I tried switching to the intel integrated graphics and strangely did not notice any changes yet again when compared to the Nvidia dedicated graphics card. In this case i was expecting a reduced performance just to see if the problem is with the graphics card being too slow. But apparently its not.

So my questions are as follows: What am i missing hardware wise or through software settings to allow me to overcome the lag issues when outliner is open with many components? And if nothing can be done about this problem in Sketchup then is it safe to say that there is a performance design flaw with outliner that needs to be addressed. In other words, do Autocad or other CAD programs have the same problem similar to outliner when refreshing many components?

And finally, on a side note, what hardware do professionals have that allows them to work on very large files without experiencing substantial screen transformation lags?

My System:
MSI GP62 6QF Laptop
Windows 10 Pro
Intel Core i7-6700HQ
Nvidia Gefore GTX 960M 2GB GDDR5 VRam
16GB DDR4 2133 RAM
1TB SATA 7200rpm
1920x1080 HD Screen
32 Bit Color Depth
60hz refresh rate

Sketchup 2017 Pro settings:
Multisample Anti Aliasing set to 4x
Use fast feedback checked
Use maximum texture size unchecked
no OpenGL warnings


#2

The delay due to Outliner updating was improved with SketchUp 2018. I think there’ll always be a little delay with Outliner open due to it’s having to be updated when you make selection changes in the model window.


#3

Thanks Dave.

It’s good to know that they did something about it. In my view it was a flaw in the program.

But with regards to the other question, what kind of hardware do professionals use to overcome general screen lags when working with very large files?

The reason i ask this question is because the processors and graphics cards they use are only slightly faster than mine. And with my system RAM and video RAM not being maxed out then that leads me to the question “what do they have that is so different than what i have?”. Could it be something like Nvidia SLI? Does Sketchup even support that?


#4

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.