Sketchup is running slow when I try to open a group or move object and triple click to select all is not working



When i use the move command or try to open/close a group it takes 5-10 seconds every time aswell as this triple clicking does not work to select all, Other commands work fine such as rotate any suggestions on how to fix this


How big is the file in Mb?


The file is 34 MB


Not that big so that’s not the problem. Does it happen in any file and any session?


no I have tried using the file on a different computer and it woks fine and other files work fine on the computer i am having the problem on


If other Sketchup files work OK, there must be something about the file you’re working on that is causing it.

If you Select All and paste into a new file, does it still happen?


Yes i tried copying it, and the problems still occured


also the file works fine on another computer so it surely cant be the file which is why i am confused by whats happening


Sounds like something corrupted.


Have you recently had an update for Win 10?
Is the Graphic card driver up to date, is sketchup using the Nvidia card or has it reverted to an onboard card, if you have one?


I dont think I have recently had an update, i installed nividia drivers today and how do i check if sketchup is using my nividia card


That could be the problem, the new driver may be causing the issue.
You could try rolling back to the previous driver and see if that fixes it.


i installed the drivers after the problem


I had the same issue as well, SketchUp seems to be slowing down a lot starting from roughly a week ago.
As it turns out, the Outliner tool, for some reason, have huge impact on performance(At least for me). After I turned it off, the lag problem seems to be solved.
Open (Window > Default Tray) and check if Outliner is enabled. If it is, turn it off.

Hope this helps you.