OS X Users: SketchUp and El Capitan


#1

Today (September 30th) is the launch day for El Capitan (OS X 10.11) which is a free upgrade for most Mac users. You may be tempted to jump out there and get it, there are reported performance enhancements and it’ll make your Mac work better with your iWatch. I’m here to say… step back, take a deep breath, and wait. Let someone more daring, someone who DOESN’T depend on their Mac for their income, make the switch first. It’s never a good idea to jump into a new operating system on the day it’s released as it will only have been mostly tested and may be missing essential drivers for your devices. It will also probably change or break the way your software works.

That being said, we aren’t tracking any big crashing issues at this point and it will likely only be an inconvenience for folks who are coming from Yosemite to El Cap. It will still break everything in SketchUp that ceased functioning as intended when upgrading to Yosemite. That is to say, if you’re still using Mavericks or Lion and you try to upgrade to El Capitan and you have something older than SketchUp 2015 then you’ll see the same level of hurt that folks felt last year.

For best results, be sure you’re using SketchUp 2015 at a minimum and make sure to back up your things and be prepared to roll back in case there are issues we haven’t discovered yet. We encourage you wait around for SketchUp 2016 (we have a new version every year now you know) before upgrading if you can help it. No, I can’t tell you when that’ll be available.

If you do jump in and upgrade, accepting the risks, then the only 2 confirmed issues we have right now are that presentations in LayOut aren’t working and importing SketchUp files into LayOut takes longer than expected. There you go, if you’re on Make then you won’t see either of those problems.

Finally, if you do upgrade and run into issues, just file them below so we and others can see what may happen if we choose to upgrade as well.

EDIT: 2 other issues I failed to mention, see the post later in the thread for more information:

  • Exporting to 3DS, OBJ and other formats takes longer in El Capitan than it did in Yosemite
  • The 2nd (and only the 2nd) time you save a file from SketchUp or LayOut it will appear that the original file is deleted or missing, to fix it just save again (a 3rd time) and everything is good again.

Happy SketchUpping!


Orbit heavy lag with Mac OS X 10.11.4
Half ball creating
#2

#3

Thanks! will patiently wait!


SketchUp and macOS Sierra
#4

If you do happen to like living on the edge, Apple just put out the first beta of 10.11.1. SketchUp and Layout continue to seem to work well. But, I don’t make my living using SketchUp, maybe I wouldn’t be so brave if I did!


#5

Have you checked on the two bugs they listed?

I could probably live without presentation mode, and a little time isn’t a big deal, but I was wondering if they were still present in the new Beta? I’ve been holding off from upgrading, but I almost upgraded to the previous public beta when you mentioned that Layout was working in the other thread.


#6

We haven’t tried it on 10.11.1… we’re not that fast. The 2 known issues we have are what’s present in the most recent (Gold Candidate) build of El Capitan. The a month ago I would have thrown out every red flag because we were getting file open and crash type problems but I think that’s all been dialed in pretty well. You can try it out, but again I urge backing up first in case you need to revert.

I’m downloading El Cap on my little testing Macbook presently to see how that works, the release version not 10.11.1, so I’ll chime back in after I’ve had a chance to see what’s happening.


#7

Under 10.11.1, inserting a large SKP into Layout seems pretty instant. I haven’t tried Presentation before, I couldn’t see how you exit the presentation, so I used control-arrow to exit that Space. Going back I found there was a white empty dialog box showing. I had to force quit to get out of Layout.


#8

Hmm, you should have just been able to press escape when you wanted to exit presentation mode. Honestly though, I would typically move the Layout docs into Keynote for a presentation anyway, I only used it as a fast way to go full screen when I needed to show someone something quickly at my desk.


#9

The Presentation issue is specifically that you can’t escape out if the Notation tool was used. Presumably without the Notation tool you can escape normally.

I’m glad to hear that there aren’t any issues with the file import in 10.11.1. I’ll presume @Marc is already or will be shortly be downloading that latest update to test against.


#10

That makes sense. Not having used presentation before I thought I was going to be able to orbit the model, but instead red lines appeared.


Layout and El Capitan
#11

Ok, there are a couple other issues I didn’t know about that do exist… I’ll add them to my first post as well, but state them here for clarity.

  • Exporting to some formats takes longer in El Cap than they did in Yosemite (eg. 3DS, OBJ)
  • The 2nd time you save a file in SketchUp or LayOut it looks like your original file disappears. It’s technically still there, but finder doesn’t refresh and show it to you. You can find it in the terminal, by saving a 3rd time (just saving again fixes the issue), or by some other action happening in that Finder window that forces the refresh. It also fixes itself after an autosave, so you might never notice it.

The simplest fix is when you save your file for the second time (which is when a backup file would normally be create for the first time) just save it again real quick and all will be right with the world.


#12

Loosely related… I’m trying to use the viewer on iOS 9.0.2 and it now crashes almost immediately. I’ve been using the viewer on my iPad Air 2 since Dropbox support was added. It had been working fine.


#13

Tested Su & LO, the file disappearing at first save did not happen. Nor from open existing, nor from new.
But I can confirm LO freezes my machine if and only if, I use annotation in Presentation mode.


#14

Hoping that one will bring thumbnails to skp and layout files. :smile:


#15

Move tool is not working properly in SketchUp - I ran to the update like a sucker - not the first time :confounded:


#16

I don’t think we know of any existing issue with the move tool in SketchUp 2015 on El Capitan… can you elaborate?

-Marc


#17

The move tool is erratic - for example, the last time i tried it - the axis snap was gone and I just couldnt move on the green axis. Since moving is one of the primordial operations - and Sketchup is my primordial tool, as Architect, I`m stuck!

I`ll temporarally go back to my VectorWorks 10 workflow - please give us an idea of deadline for the update - Thank you!

Att.

Arqt° Maurício Checchia

11 97112.4499
19 99955.4499


#18

Can you give example exact steps that will always show a problem? I’m using the next version of Mac OS (10.11.1), and maybe something has been improved by Apple.


#19

I just uploaded a video to show you what happen in SketchUp LayOut.
I would like to know what time can fix this problem and please don’t mind my poor english. Thank you!

Mac OS version:
10.11(15A284)

LayOut version :
14.1.1283


#20

That problem showed in SketchUp 2015 until I think the beta 6 of 10.11. Haven’t seen the issue since then, and it still seems to work ok.

Can you try using SketchUp 2015 instead of 2014?

http://www.sketchup.com/download/all