Orbiting and Zooming with Mouse and 3D Mouse

This one’s a bit odd and I don’t know if it’s a bug, a setting or my old brain. I’m running SketchUp 2022 on OSX Monterey. I’m using a Microsoft Bluetooth 3600 mouse along with a 3DConnexion SpaceMouse Compact. As far as I know all drivers are up to date.

My problem is that when I am trying to orbit with the regular mouse it tends to use whatever object the pointer is over when I start orbiting as the center of the orbit. If the pointer is over a wall it orbits around the wall, whether it’s selected or not. If the mouse happens to be over the sky then the entire model spins off into a Kansas tornado. Even if I have an object selected, but the mouse cursor is not on top of it it will still orbit around whatever the pointer is over.

This gets very frustrating if you have a very simple model where most of the screen space is empty. unless you make sure the cursor is over something it all flies away.

It does the same with the 3D mouse. The pivot point changes to whatever the cursor is over.

When I spend the extra time making sure the cursor is over what I want to orbit and then zoom in or out with the wheel, if the cursor ends up over anything else during that time it will orbit using the other object. This is very frustrating when zoomed into something close and the cursor just happens to be over an open space and the model suddenly zooms way out.

When I’ve watched Aaron’s live streams it doesn’t appear that he has the same issues.

Am I just an old guy yelling at the sky, or is there some setting I can change?

Thanks
Randy

Correct. This is designed behavior for native orbit, the center of rotation is set to whatever geometry the mouse is clicked on. It’s a good system that allows for smooth intuitive navigation through the model at large and small scales, once one gets used to it, but one must be intentional about where one starts an orbit.

Click the left hand button on the SpaceMouse to bring up the options. Do you have it set to Object mode? Or? And, check what the center of rotation is set to.

Assuming you haven’t changed the default action for that button. :grinning:

1 Like

Thanks for the fast response. I didn’t know the two buttons were assigned to anything. It was set to Object Mode and Rotation Center Auto and Use selected item already.
Interesting that if you turn off Auto and have nothing selected orbit stops working on both the mouse and 3D mouse. That makes sense of course.
The fact that I was already using the default settings indicates that everything is operating properly and I just need to work within it. I guess just keep better track of what I have selected. I also have those other modes to learn as well.

Thanks again.
Randy

1 Like

As you can see by my reply to endlessfix, I found the left click menu on the 3D Mouse. Who knew? Thanks for the quick information!
Randy