Orbit Tool Pivot Point When Clicking Outside Geometry

orbit
camera
pivot

#1

When orbiting inside a small group or component, with the rest of the model hidden, you have to click on geometry for the camera not to go crazy. If you click slightly to the side of any geometry the orbit tool chooses a pivot point far away in the distance which moves the camera far to the side where you can no longer see your work.

Experienced users are so used to this that we hardly even notice it anymore. We just make sure to click the geometry, not the background. For beginners on the other hand I think this specific issue is the cause of much frustration and is the reason why many new users seem to hate SketchUp camera control while experienced users love it. I’ve even heard other students saying they don’t use SketchUp because of the crazy camera :open_mouth: .

If you zoom out to view the whole model and orbit it by clicking in the background it orbits as you would expect, without losing the model from sight. If you copy your small group/component to a new fresh file and edit it there instead you also experience the expected orbit behavior. If you are inside the small group or component on the other hand, with the rest of the model hidden, it seems the model is orbited around the far end of its bounding box, causing what you work on to disappear from sight.When the rest of the model is shown this isn’t much of a problem as there is usually geometry where you click.

If this behavior could be tweaked to make the bounding box of the open group/component, instead of that of the model, define the orbit pivot point when clicking outside geometry, I think orbiting in SketchUp would be greatly improved and a lot of new users would stick to using SketchUp instead of abandoning it.


Orbit pivot point
#2

As a comparison this is how orbit behaves when the component alone is copied to a “fresh” model. This is how I want the camera tools to behave also when editing the component inside of a physically larger model!

Btw, this all applies to zoom too, not just orbit.

@Katya, how do you think an update in this behavior would benefit new users, based on your experience as a trainer?


#3

You make excellent points! For both beginners and people like me who forget my own lessons sometimes.


#4

A zoom selection to bounding box would certainly help.
Or the grey ‘editing’ modus of the bounding box somewhat larger, as long when you click inside the bounding box, it appears to behave more accurately.


#5

If the rest of the model is hidden this is the same as zoom extents.

The gray lines is a visual cue telling you you are inside a group/component. I really don’t think it affects the camera tools. On the other hand increasing its size could lead to users not knowing they are inside a group/component when zoomed in close as the lines could be outside of the screen.


#6

@trent Do you know who would be best to talk to or ask about this? This experience is something I too have found incredibly inconvenient in my own modeling, and Christina documented the issue really well here.


#7

Also, @eneroth3 - cool model!


#8

When model info is set to hide rest of model, the grey lines would not be necessary, grey lines are needed when you edit the group/component with that setting off. If you are zoomed in close enough, meaning that the group/component covers a substantial area of the screen, the pivoting acts as if you would expect it to behave, the glitches start when the group covers a relatively small area.


#9

The lines are needed the most when the rest of the model hidden. With the rest of the model shown you see the whole model around you grayed out. When the rest of the model is hidden these lines are the only visual cue there is to being inside a group/component in a larger model rather than editing it in a separate model (when switching between multiple open windows this is good to know).

In my experience this happens when you are just slightly outside the geometry with the mouse. If there are holes in the group/component it can very easliy happen. Navigating the camera when being inside a wire frame group/component, e.g. an imported DWG drawing can be nearly impossible. That is one of the primary reasons why I made an extension that merely adds a backdrop face to groups(components: https://extensions.sketchup.com/en/content/eneroth-2d-plane.


#10

glad I found this post, and thank you @eneroth3 for explaining this issue so well.

@trent any thoughts/was this logged? Very interested in a solution.


#11

Hi all, an issue is open to look at this. The advise I give during training is to reiterate, where your cursor is pointing is where you are going… both to or from. Orbit behaves in much of the same way and in conditions like described above this comes into play all the more. Once your cursor is off the face, you are pivoting around an axis point that is anyones guess.

One feature I use constantly when is the context click ‘Zoom Selection’. This does help me to frame the object better when it is isolated… though… I still hit this issue at times.

Trent


#12

This is especially annoying for components with holes in, as you very easily pick an orbit/zoom “pivot” through the whole.


#13

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.