Orbit is sluggish in Sketchup 2017 on Windows 7


#1

I just upgraded from SU16(Make) to 17(Make) and the Orbit function behaves differently. It is slow to begin responding to mouse moves. I did not did not have this problem with SU2016. (I’m using Windows 7, graphics on the motherboard; same computer that had no problems with SU2016 orbit.) Has anyone else experienced this?


#2

There are several possible reasons. Start with correct installation method. Did you right click on the installer file and choose Run as administrator? This is required for proper installation. See: Why the installer must be "run as administrator"

Next, make sure that your Radeo GPU drivers are up to date. In SU2016, you could offload graphics rendering to the CPU (turn off Hardware Acceleration) but that’s not an option in SU2017. Now you must have a GPU that is up to the task.

Finally, there have been numerous reports of sluggishness caused by some bad Windows updates. There are threads about this here on the forum. You may have one or more of those problem update files installed and need to remove them. See this thread: Selection Tool process is slow, unbearably slow


#3

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.