Orbit does not work and neither does pan


#1

Here is the issue I am having: there is absolutely no way to rotate the model. I left sketchup running overnight, I have done this multiple times without issue however this time whenever I try to rotate the model… Nothing nada just the pan sign, yet when I try to pan it the thing does not move one single inch… Please help as Sketchup is literally the only software I can use because other software like 3DS Max, Wings, Milkshape, Etc. are impossible to use and therefore inferior, so therefore I want to get this fixed asap.


#2

Have you tried various Preferences > OpenGL setting ?
This might improve matters - at least temporarily …
If so consider trying to upgrade your Graphics Card driver, and readjust those settings again…


#3

Upgrading the drivers now I have a gaming laptop so I cannot really do much here except for that… If that does not work then what?


#4

Okay none of that worked I updated the drivers and it is still doing the same thing I am currently uploading a video that shows what my problem is in full.


#5

Have you tried different OpenGL settings ?

You have not yet thought to give us details of your OS, Versions, Graphics-Card etc…
all of which might help us in helping you…


#6

My OS is Windows 7 Service Pack 1
Intel Core i5-4200M CPU @ 2.50GHz
8 Gigs of ram
the OS is 64 bit.
Graphics Card is a GeForce GT 750M


#7

OK, your set up is not very dissimilar from mine - that works fine for me ! …
So something is adrift…
Can you please explain the exact steps you take to ‘rotate the model’…
and of course what results from that !
Can you also post an example SKP with this issue present ?


#8

Okay
Step 1. I click on "Orbit"
Step 2. I try to drag the cursor to no avail
Step 3. I move over to "Pan"
Step 4. Once again I try to move the cursor, again no dice
Step 5. Fiddle with settings and repeat from step 1
Video of the problem


#9

Hi,

just to clarify beyond the shadow of a doubt… ‘Step 2. I try to drag…’

There is a ‘Click’ that initiates this tool and it needs to be ‘Held Down’ while that drag is happening. Selecting the tool and moving it around isn’t enough on it’s own. Same goes with the Pan tool as well.

And you probably know this already, it’s so common place it doesn’t get mentioned in detail… and in the end it’s implied in the term drag anyhow. ( but just to check I’m afraid – Sorry about that ).

So assuming that’s all okay;



I wonder what the preference settings are for your USB mouse.

Have you gone through these and modified any button clicks at some point in the past. The click I mention should be a left click and if buttons were reassigned to something other than the typical layout—that might be something to think about.

I don’t see this sort of problem mentioned very much around here, and at the moment I’m curious about how a usb mouse might cause problems with an otherwise normally functioning tool such as orbit/pan.

Also, have you tried to run the orbit tool from the trackpad on your laptop (mouse being connected, and again as disconnected)?

Same results using the trackpad?.. if not then does a different mouse work as expected?

Also, you might try pluging this same mouse into a different usb port on your laptop to see what happens.

I think it’s worth trying to focus on proving that the mouse is functioning perfectly before jumping into the next phase of troubleshooting [whatever that might be].

Even re-setting the mouse properties might make difference. And while your at it check into what set of drivers it might have… maybe thay need updating if they are custom drivers. I’m not sure how alienware handles it’s mouse drivers, but I wouldn’t be surprised if they have modifications for better gaming experiences, or whatever. Perhaps that’s at work here with this orbiting issue.


#10

I have tried using the trackpad but keep getting the same results… However I will try to look into the mouse drivers tomorrow as I am going to sleep…


#11

Updating drivers is usually a good idea, But, if the trackpad produces the same results, then that sort of points towards other things.

Before checking it might be easier to try a different mouse if one happens to be laying around. Success with that running on the default hardware drivers of your OS would be good news. And if it didn’t work then I guess this troubleshooting effort moves onto the next level.

2 different input devices, much less 3, getting the same results with different device drivers can’t all be wrong.


#12

Mine occasionally screws up and does that: normally it’s tied with a windows update - I have to actually shut-down the machine and re-start it. (Rather than simply putting it to sleep by closing the lid or hitting the power button)


#13

Is the Outliner window open ?
Is textures on in the current style ?


#14

Are Shadows on or off?

What size is your model (Edges, faces, see Window menu>Model Info>Statistics, with Components included)?

Does this also happen if you start a new model with only, say, a simple box in it?


#15

Thanks that fixed it… I had like 18 updates as I have auto updates turned off.