Option to apply X-ray to selected objects

Hi everyone,

I was working with SketchUp just now, and at some point I realized that the x-ray effect was being applied to objects I selected, and if I hovered over a component while using the move tool, the face that my cursor was over would become transparent. This was very helpful, because I could actually select an edge or point that I would normally not have been able to select without hiding objects or tags.

While the regular X-ray or Back-edges works fine, it can be a little overwhelming/chaotic if all lines are suddenly visible.

I think this is not an intended function, since the effect disappeared when I saved my file, and I don’t know how I would have turned it on (if it is a function, please tell me how to activate it, because it was really useful).

I have included a small video to show the selection part. For some reason my cursor is not in the correct place in this video.

I have some extensions that might have caused this, but again, I don’t know how I would have turned it on, so I doubt it would be intentional either way.

It actually is an intended function and it kicks in when the object would otherwise obscure the point you’ve grabbed with the Move tool.

hello,

this feature has been introduced with sketchup 2020
" New grips on bounding boxes
When you grab a point that is obscured in an object (such as a back corner or centre point) and start to move it, your object will automatically go transparent when something in your model interferes with the object you are moving. This works with both the Rotate tool and Move tool. This will literally ‘transform’ your workflow. Don’t take our word for it: start positioning objects in hard to reach places to see what happens!"

1 Like

Thanks, does this also cover the selecting? It’s not nearly as useful, but can be helpful.

no it should not. Only with the move or rotate tool

This looks like a bug. Objects should become temporarily transparent in very specific situations so you can select points behind/within them. This shouldn’t happen when selecting. If you restart SketchUp I would imagine this to be gone.

It might be a graphics card issue. Download and install the latest driver from the chipset manufacturer’s website. If you have a separate graphics card and an integrated display chip, make sure that SketchUp is using the discrete graphics card. Also check that the Fast Feedback setting (Window menu>Preferences>OpenGL) is right for your type of graphics (generally On for discrete graphics, Off for an integrated chip).