Select tool Problem

help

#1

Hi! So I’ve been using sketchup for about 6 months now, and this isn’t the first time I encountered this problem or feature that I just don’t know. My select tool selects through walls even without Back Edges enabled. The first time it came it just fixed it on its own, I don’t know how. I’ll add a picture to show the problem. Does anyone know how to fix this? Also, it’s not just this file that’s like that, it also happened on other files when I tested it

Here’s me selecting from the back


#2

Unfortunately, I can only put one picture, here’s what happened when I did that

Then, it also selects the front :confused:


#3

Sounds totally normal to me if you are selecting with a selection window. Unless I misunderstand you its totally unrelated to back edges.


#4

Isn’t Back Edges a ‘visibility’ setting? allowing you to see them, or not, depending upon the setting that’s chosen.

I’ve never considered it to be something that changes how SU filters the geometry for it’s selection box tool.

You might look into some of the Selection Tool Plug-ins… There is one which expands on the options though I can’t recall it be name at the moment.


#5

Hm you guys are right I think, I just saw a thread with the same problem and the video that was the solution said it was normal. Thanks! I might’ve just not noticed it before


#6

If you toggle the view to wire frame it will help you see what is selected behind.


#7

Is there any fixes though, to maybe just select what I see, and not the objects behind it too?


#8

This native window_selection behavior is normal and has always been like you described: all geometry within the window from what you see to infinity through faces etc.
There certainly might be a plugin that allows you to only select the foreground geometry, not what is currently behind other geometry. You’ll have to search the “selection toys” plugins, Thomthom’s plugins maybe?


#9

Here is one of many videos pertaining to the different ways you can use the Select Tool to select what you need.

Cheers
CD


#10

For the benefit of readers who may stray upon this topic: the behavior the OP describes applies only when you use a selection box (click and drag out a box to select entities). It does not happen when you click on entities one at a time to add them to the selection. This is the way the selection tool’s boxes have alway worked, they consider the x,y extent on the view but go to unlimited depth into the view.


#11

Thanks! Didn’t know that it was normal to be like that. Again, thanks guys!


#12

Hello…If you view it from the side, you will be able to select a portion.
Remember you can make components and groups…they are easier to “Move” .