Opening 2017 files in 2018

I’ve just changed from Apple to a (horrible) windows PC with a view to running Articad.

Upon installing SU on the new machine I thought I may as well install the 2018 version.

When I open a drawing that was done in SU 2017 it appears, but if I dare to click on anything, try to pan the view, or do anything then it freezes for 20-30 seconds.

When it eventually registers any of the above, when anything else is attempted again the same happens.

Any thoughts?

The new machine is a Dell, with an i7 processor so performance wise should be even better than the Apple!!!

Update!!!

It isn’t even when opening files… it’s just any work in SU!!! I just tried a new drawing and it’s doing the same?!!

AAAAAAAAAAAAAAAAAAAAAAA!

When you installed 2018 did you right click on the installed file and then click Run as administrator? That seemed to make a difference and man others on this and the SketchUcation forum. I have not had any problems opening or working with files from any version…

Have you tried installing SU 2017 on the same machine to see if there is any difference?

Hmmm… I’ve just run the Sketchup checker tool, and it says the graphics card isn’t up to it. Surely that can’t be right? I have only had this a few weeks, and it’s an £800 laptop?!!

I could try installing 2017 I suppose…

Thanks!

What graphic card does it have?

it says: “Intel® UHD Graphics 620”

It was this one I purchased:

Please tell me it’s fine?!!

There are a lot of posts and several threads about this issue - search for ‘slow selection’. It seems mainly to be caused by:

  • always slightly dodgy OpenGL support for the common Intel integrated graphics chips used in many laptops
  • out of date graphics drivers (or sometimes driver updates that ‘break’ previously working drivers)
  • some Windows 10 updates that break the OpenGL graphics chain
  • using the built in graphics instead of separate graphics card where a laptop has one of each

SU isn’t the only program to suffer from the Windows updates, but it seems to be a common cause of problems for SU, judging by the volume of forum posts about it.

SU 2017 suffers from many of the same problems, for the same reason - inadequate implementation of what SU now requires - good drivers for OpenGL 3.0 or better.

There is a fix for SU2018 (not applicable to 2017), which worked for me on an old HP laptop with Windows 10 and an out of date Intel HD 3000 chip.

See potential fix

The model laptop you have also has an AMD Radeon 530, you might have to tell your computer to use that graphics card when using SketchUp instead of the Intel UHD 620

Thanks! Sounds interesting… how do I do that?

thanks for this… I’ll try it now.

I’ve just set both battery/plugged in to ‘maximize performance’ and it seems to have fixed it… best keep it plugged in now then?!!

Thanks for your help everyone.

Quite why these things have to be so complicated, I don’t know!

1 Like

Oh, I had a similar problem just some weeks ago but had completely forgotten bout it. I usually have my laptop permanently plugged in and use it more or less as a desktop computer. When I ran on batteries s when I was abroad and didn’t have an adapter with me SketchUp crashed on launch. Turned out it was the energy saving feature that interfered with SU, probably by disabling the graphic card.

Checking if the computer is in energy saving mode should probably be on the list of things to check when an error occurs.

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.